Page MenuHomePhabricator

Memory leak on Wikidata
Closed, InvalidPublic

Description

Hi,

I have some memory leak issues, since few days.
I'm a MacBook Air 2015 (Mojave) with Google Chrome, to edit Wikidata with my account.

Screenshot today on page https://www.wikidata.org/wiki/Wikidata:2020_report_on_Property_constraints the tab used 4,2 Go memory :

Capture d’écran 2020-04-26 à 00.48.09.png (47×823 px, 15 KB)

I have special javascript from https://www.wikidata.org/wiki/User:Manu1400/common.js but it's the same code since 11 april 2018.

And i have CPU issues with Google Chrome since few days.

Event Timeline

Reedy added a subscriber: Reedy.

Did you have the tab open for a long time?

Screenshot 2020-04-26 at 20.52.18.png (48×1 px, 21 KB)

This isn't seemingly an issue with Wikidata, nor with MediaWiki. The page isn't very big, and it doesn't seem very complex either

<!-- 
NewPP limit report
Parsed by mw1393
Cached time: 20200426030614
Cache expiry: 2592000
Dynamic content: false
Complications: []
CPU time usage: 0.992 seconds
Real time usage: 1.469 seconds
Preprocessor visited node count: 18284/1000000
Post‐expand include size: 247008/2097152 bytes
Template argument size: 36996/2097152 bytes
Highest expansion depth: 13/40
Expensive parser function count: 1/500
Unstrip recursion depth: 0/20
Unstrip post‐expand size: 104/5000000 bytes
Number of Wikibase entities loaded: 0/500
Lua time usage: 0.352/10.000 seconds
Lua memory usage: 2.07 MB/50 MB
-->
<!--
Transclusion expansion time report (%,ms,calls,template)
100.00% 1095.330      1 -total
 58.94%  645.613     26 Wikidata:2020_report_on_Property_constraints/ctype_links
 58.22%  637.730     26 Template:Q'
 57.93%  634.487     82 Template:Label
 40.35%  441.955     39 Template:Q
 21.65%  237.160     43 Template:P
 21.06%  230.643     52 Template:Hideable_span
 14.02%  153.545     52 Template:TranslateThis
 11.27%  123.492     26 Template:Reasonator
  8.99%   98.431     26 Template:SQID
-->

I have special javascript from https://www.wikidata.org/wiki/User:Manu1400/common.js but it's the same code since 11 april 2018.

It's a bit difficult to say it hasn't changed when you're loading various scripts from other users

I have some memory leak issues, since few days.
And i have CPU issues with Google Chrome since few days.

It sounds a lot like some issue from an update with Chrome. Maybe they released a buggy build.

There's not much we can do about that. Wait for an update to Chrome and update. Maybe even use Help -> Report an issue and send them the screenshot and description of the page you're having issues with.