Page MenuHomePhabricator

User global preferences relating to preview in editing mode is corrupted
Closed, InvalidPublic

Description

This problem seems to be related to my global account when I log in as "Ineuw", regardless of the browser and OS. and on every site related to my "global" login.

The bug:
When logging in with my regular account "Ineuw", when activating "Show Preview" in edit mode,
the preview frame is displayed below the text edit boxes.

Expected mode:
Without login, or logging in with my alternate account, when activating "Show Preview" in edit mode, the preview frame is displayed above the text edit boxes.

Steps taken to rectify:
Reset Preferences to default.
Removed vector.js and .css
Cleared browser cache and site data
Logged out and deleted all wikmedia related cookies
Logged back into the account but the problem remained.

Test & sites
Browsers tested Firefox 75.0
Vivaldi 3.0.1874.32 (Stable channel) (64-bit)

OS tested
Windows 10 Pro
Linuc Mint 19.3

https://en.wikipedia.org/
https://en.wikisource.org/
https://fr.wikisource.org/
https://commons.wikimedia.org/
https://www.mediawiki.org/

Event Timeline

Ineuw created this task.Apr 26 2020, 1:34 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 26 2020, 1:34 AM
Ineuw updated the task description. (Show Details)Apr 26 2020, 1:35 AM
Ineuw updated the task description. (Show Details)Apr 26 2020, 1:39 AM
Ineuw updated the task description. (Show Details)
Restricted Application added a project: Community-Tech. · View Herald TranscriptApr 26 2020, 2:32 AM
Aklapper added a subscriber: JJMC89.

@JJMC89: I don't how ProofreadPage behavior is related to the GlobalPreferences extension.

Aklapper changed the task status from Open to Stalled.EditedApr 26 2020, 12:33 PM

@Ineuw: A full and clear list of complete steps would be very welcome: Which exact websites (full URLs) is this about? Which web browsers and web browser version has this been tested with? Can you please provide a complete list of steps to reproduce which leave no room for interpretation? It is also unclear to me how this is related to global preferences at all, as the steps mention nothing about that. Please follow https://www.mediawiki.org/wiki/How_to_report_a_bug as requested before - thanks.

Ineuw updated the task description. (Show Details)Apr 26 2020, 8:25 PM

The Preference options in my second account IneuwPublic differ from the Ineuw account in that there are no global account settings.

@Ineuw: Okay. I still have no idea what are the complete steps to reproduce some problem; see the sentences in my previous comment which come before "It is also unclear to me how this is related to global preferences at all".

Ineuw added a comment.Apr 27 2020, 9:03 PM

I assume that it has to do with "global" because I am always logged in automatically on every visited wiki website and the same problem persists.

Having to guess steps, here is what I tried:

Please try safemode as described on https://www.mediawiki.org/wiki/Help:Locating_broken_scripts and share the results.
Also wondering if this happens when using the debug=true URL parameter and/or when using different skins via the useskin=timeless etc URL parameter.

Also, what exactly are all the settings under "Preview" on https://en.wikisource.org/wiki/Special:Preferences#mw-prefsection-editing ?

Ineuw added a comment.Apr 28 2020, 6:58 AM

You and I have taken exactly the same steps, in the same sequence and as you can see in the attached photo. The photos were taken hours ago and doublchecked them now. I noticed that the global preview is checked and the user preview is blank.

F31783946 are the global settings and F31783960 are the user's settings. I must log out and check my public user id editg settings

Ineuw added a comment.Apr 28 2020, 7:05 AM

IneuwPublic has no global account on Wikimedia and the User Preferences Preview display is selected, which works.

Ineuw added a comment.Apr 28 2020, 4:57 PM

@Aklapper If I am correct, perhaps the title of this ticket should be changed to something like "Link between Global preferences and Local preferences is broken"?

Ineuw added a comment.Apr 29 2020, 6:19 AM

Disabled Global preferences and the preview is working properly.

@Ineuw

  1. As we discussed in enWS, your preview positioning is set in preferences, you can ignore all components of the skin, none of the skin matters.
  2. There is globalpreferences, on the EDITING tab where you set your preferred global default for preview positioning Show preview before edit box
  3. There is a local wiki preference where you can override your preferred global (same text)
  4. If your globalpreference changed the most likely explanation is the you did it, maybe without realising you were in your globalpreference
  5. If you can set it and it saves and it propagates, then all this conversation is not required

Yes, your global preferences will differ between accounts, that is expected. It is also irrelevant, what is needed is

  1. that you can change your globalpreference
    1. to your preferred

save it have it stick.

Then at the wikis where you are editing that you have ensure that your local preference takes the global, or is set locally to how you wish it.

Please do that on your Ineuw account and tell us the result. All you have done above is complicate the matter with a whole lot of noise, and not matters to resolve your "preview" issue.

Ineuw added a comment.May 8 2020, 9:07 AM

The Global preferences were not set up correctly, and the setting didn't cascade to the local preference. The second checkbox was unchecked, the purpose of which I don't understand. Why some of the the Global references have a pair of checkboxes. I searched Mediawiki for an explanation but found nothing. In my case, the left checkbox was selected and the right wasn't. This is indicated in the attached image.

I don't remember seeing the Global Preferences for years, and I didn't remember accessing it from local settings. If my memory is correct, I set it up through Wikimedia when it was introduced. Was there modification to the Global Preferences code recently?

Aklapper closed this task as Invalid.May 8 2020, 11:12 AM

Why some of the the Global references have a pair of checkboxes.

https://www.mediawiki.org/wiki/Help:Extension:GlobalPreferences . If not covered, please comment on the talk page.

If I uderstand correctly then there is nothing to fix left in this ticket, hence closing.

Ineuw added a comment.May 9 2020, 1:30 AM

Much thanks @Aklapper and @Billinghurst. The info is missing and I will pursue it in the talk pages.