Page MenuHomePhabricator

Can't change article language
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
1-open the app
2-go to an article
3-go to the language option on the quick action menu

Actual Results:
I see a never ending "loading languages" gif

Expected Results:
the list of languages should appear

Event Timeline

Jpita created this task.Apr 28 2020, 12:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 28 2020, 12:12 PM
Jpita triaged this task as Unbreak Now! priority.Apr 28 2020, 12:12 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptApr 28 2020, 12:12 PM
AMuigai moved this task from Bugs to Kanban on the Inuka-Team board.Apr 28 2020, 12:14 PM
AMuigai edited projects, added Inuka-Team (Kanban); removed Inuka-Team.
Reedy renamed this task from [UNBREAK NOW] can't change article language to Can't change article language.Apr 28 2020, 12:39 PM
hueitan claimed this task.Apr 28 2020, 12:49 PM
hueitan moved this task from Backlog to Dev on the Inuka-Team (Kanban) board.
hueitan added a subscriber: AMuigai.
hueitan added a comment.EditedApr 28 2020, 3:38 PM

The main reason for causing this error because the browser doesn't support Intl.PluralRules (supported after firefox 58)

one place where this is used, is banana-i18n, it remove the workaround of PluralRules with the native Intl.PluralRules in this commit https://github.com/wikimedia/banana-i18n/commit/61b0b9cddcc2f06f440a8e3480ae5273dcb7b999

but this can be several places around the different dependency,

to make sure our project keeps update with all the dependencies, we need to find the polyfill for Intl.PluralRules

AMuigai closed this task as Resolved.May 5 2020, 5:29 PM