Page MenuHomePhabricator

Call to undefined method MediaWiki\Extension\MachineVision\Hooks::onRollbackComplete()
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.35.0-wmf.30

message
Call to undefined method MediaWiki\Extension\MachineVision\Hooks::onRollbackComplete()

Impact

Has happened a couple of times after promoting train to group1. Not enough to be a train blocker or UBN yet.

Details

Request ID
Xql8PwpAMMAAA8FOCIUAAABB
Request URL
https://commons.wikimedia.org/w/index.php?title=File:Polly_Pons.jpg&action=rollback&from=As4pass&token=0af7b039fc1c73d19147ce087f4f7b005ea97c2f%2B%5C
Stack Trace
exception.trace
#0 /srv/mediawiki/php-1.35.0-wmf.30/includes/HookRunner/HookContainer.php(126): MediaWiki\HookRunner\HookContainer->callLegacyHook(string, array, array, array)
#1 /srv/mediawiki/php-1.35.0-wmf.30/includes/Hooks.php(135): MediaWiki\HookRunner\HookContainer->run(string, array, array)
#2 /srv/mediawiki/php-1.35.0-wmf.30/includes/page/WikiPage.php(3444): Hooks::run(string, array)
#3 /srv/mediawiki/php-1.35.0-wmf.30/includes/page/WikiPage.php(3196): WikiPage->commitRollback(string, string, boolean, NULL, User, array)
#4 /srv/mediawiki/php-1.35.0-wmf.30/includes/actions/RollbackAction.php(122): WikiPage->doRollback(string, string, string, boolean, NULL, User)
#5 /srv/mediawiki/php-1.35.0-wmf.30/includes/actions/RollbackAction.php(85): RollbackAction->handleRollbackRequest()
#6 /srv/mediawiki/php-1.35.0-wmf.30/includes/MediaWiki.php(519): RollbackAction->show()
#7 /srv/mediawiki/php-1.35.0-wmf.30/includes/MediaWiki.php(305): MediaWiki->performAction(ImagePage, Title)
#8 /srv/mediawiki/php-1.35.0-wmf.30/includes/MediaWiki.php(973): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.35.0-wmf.30/includes/MediaWiki.php(535): MediaWiki->main()
#10 /srv/mediawiki/php-1.35.0-wmf.30/index.php(47): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): require(string)
#12 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 29 2020, 1:10 PM
Restricted Application added a project: Structured-Data-Backlog. · View Herald TranscriptApr 29 2020, 1:16 PM

Caused by rEMVI677253ed5cc509bba1bf3f013b79896655b039b3; cc'ing @DannyS712.

It appears that the method wasn't renamed.

Restricted Application added a project: User-DannyS712. · View Herald TranscriptApr 29 2020, 1:17 PM

Change 593231 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/MachineVision@master] Fix hook handling for RollbackComplete hook

https://gerrit.wikimedia.org/r/593231

Caused by rEMVI677253ed5cc509bba1bf3f013b79896655b039b3; cc'ing @DannyS712.

It appears that the method wasn't renamed.

Edit conflict :) already sent a patch

DannyS712 triaged this task as High priority.EditedApr 29 2020, 1:19 PM
DannyS712 moved this task from Unsorted to Awaiting review and deployment on the User-DannyS712 board.

^ Not a train blocker, since if I recall the extension is only deployed on commons, but the hook isn't processed anymore

Concur, not a train blocker at this time. Has happened about 13 times now. If the count grows rapidly, we may need to fix it quickly.

DannyS712 updated the task description. (Show Details)Apr 29 2020, 3:45 PM

Change 593231 merged by jenkins-bot:
[mediawiki/extensions/MachineVision@master] Fix hook handling for RollbackComplete hook

https://gerrit.wikimedia.org/r/593231

Change 593267 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/MachineVision@wmf/1.35.0-wmf.30] Fix hook handling for RollbackComplete hook

https://gerrit.wikimedia.org/r/593267

Change 593267 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/MachineVision@wmf/1.35.0-wmf.30] Fix hook handling for RollbackComplete hook

https://gerrit.wikimedia.org/r/593267

Backport scheduled for swat: Wednesday, April 29 18:00–19:00 UTC morning swat

Change 593267 merged by jenkins-bot:
[mediawiki/extensions/MachineVision@wmf/1.35.0-wmf.30] Fix hook handling for RollbackComplete hook

https://gerrit.wikimedia.org/r/593267

Mentioned in SAL (#wikimedia-operations) [2020-04-29T16:54:15Z] <jforrester@deploy1001> sync-file aborted: Fix hook handling for hook T251408 (duration: 00m 02s)

Mentioned in SAL (#wikimedia-operations) [2020-04-29T16:55:29Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.30/extensions/MachineVision/src/Hooks.php: Fix hook handling for hook T251408 (duration: 01m 05s)

Jdforrester-WMF closed this task as Resolved.Apr 29 2020, 4:56 PM