Page MenuHomePhabricator

"Reply" link triggering the wrong message AR Wiki
Closed, ResolvedPublic

Description

This page in AR wiki https://ar.wikipedia.org/wiki/%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7:%D8%A5%D8%AE%D9%81%D8%A7%D8%A1_%D8%A3%D8%B1%D9%82%D8%A7%D9%85_%D8%A7%D9%84%D8%A2%D9%8A_%D8%A8%D9%8A shows the "Reply" link in front of comments with signature. When these links are clicked, a wrong message appears about missing/moved comment.
This message is: Could not find the comment you're replying to on the page. It might have been deleted or moved to another page. Please reload the page and try again.

But this is not the case, comments are not moved/deleted. And if the page is reloaded nothing changes.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 4 2020, 10:59 PM
Dyolf77_WMF added a comment.EditedMay 4 2020, 11:08 PM

This page contains comments from users in separate subsections created by the pre-load red button in the page which creates a subsection == Username ==, but these sections are moved manually to ==== Username ====.
If we keep the order of the section as the button does the "REPLY" works fine.

The tool can't find the comments on that page, because the timezone indicators in the timestamps ((UTC) in English) are written as (ت ع م) (with the HTML entities) instead of (ت ع م).

Looks like most of them have been changed in this edit: https://ar.wikipedia.org/w/index.php?title=ويكيبيديا:إخفاء_أرقام_الآي_بي&diff=prev&oldid=46521562. I assume this was somehow accidental, since the edit is otherwise a revert.

If this happens regularly, we'll have to handle this case.

Apparently the wikEd tool replaces the entities like this, the problem is common enough that en.wp has a shortcut link to the explanation: https://en.wikipedia.org/wiki/Wikipedia:WIKEDNBSP

Change 594567 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Handle   and other entities in the timestamp/timezone

https://gerrit.wikimedia.org/r/594567

Change 594567 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Handle   and other entities in the timestamp/timezone

https://gerrit.wikimedia.org/r/594567

Ryasmeen edited projects, added Verified; removed Editing QA.May 29 2020, 8:30 PM
ppelberg closed this task as Resolved.Jun 1 2020, 1:28 AM