Page MenuHomePhabricator

Make TimelineRowFormatter::getLinks do the same checks as it is currently done in SpecialCheckUser
Closed, ResolvedPublic2 Estimated Story PointsJun 2 2020

Description

This is a follow up patch on top of https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CheckUser/+/594615

See: https://gerrit.wikimedia.org/g/mediawiki/extensions/CheckUser/+/53ffb05ad1e4e7b7a5fa419e2229f686ce662c36/includes/specials/SpecialCheckUser.php#1956 for details on how it should work.
There is already a placeholder for this at TimelineRowFormatter::getLinks

Summary from the AHT planning meeting: This task is for checking the links are laid out correctly in each row - we may need to make a small fix, or we may need to do nothing. T251465: Investigate how to handle SpecialCheckUserGetLinksFromRow on SpecialInvestigate is for adding the new hook.

Event Timeline

dmaza created this task.May 6 2020, 3:47 PM
Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptMay 6 2020, 3:47 PM
Niharika triaged this task as Medium priority.May 7 2020, 3:35 PM
Niharika set Due Date to May 12 2020, 7:00 PM.
Niharika changed the subtype of this task from "Task" to "Deadline".

Change 596056 had a related patch set uploaded (by Dbarratt; owner: Dbarratt):
[mediawiki/extensions/CheckUser@master] Replace the SpecialCheckUserGetLinksFromRow hook with CheckUserGetLinksFromRow

https://gerrit.wikimedia.org/r/596056

I couldn't see anything else to do for this task other than add the hook. If that's the case, is this a duplicate of T251465?

dbarratt updated the task description. (Show Details)May 13 2020, 4:49 PM
dbarratt updated the task description. (Show Details)
ARamirez_WMF set the point value for this task to 2.May 13 2020, 4:51 PM
Tchanders updated the task description. (Show Details)May 14 2020, 12:37 PM
dbarratt removed dbarratt as the assignee of this task.May 14 2020, 4:43 PM
dbarratt added a subscriber: dbarratt.

@dbarratt What happened to this task? Did I miss an update during standup? ๐Ÿค”

@dbarratt What happened to this task? Did I miss an update during standup? ๐Ÿค”

The patch was moved to T251465
See: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CheckUser/+/596056/4//COMMIT_MSG#18

Looks like the only thing to do here is add the . . separators, as in the description of T237595

Change 597041 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/CheckUser@master] TimelineRowFormatter: Format rows with correct separators

https://gerrit.wikimedia.org/r/597041

ARamirez_WMF changed Due Date from May 12 2020, 7:00 PM to Jun 2 2020, 7:00 PM.May 21 2020, 3:13 AM

Change 597041 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] TimelineRowFormatter: Format rows with correct separators

https://gerrit.wikimedia.org/r/597041

dom_walden added a subscriber: dom_walden.

Separators in the timeline tab now look like:

New page creations and edits are now consistent with the acceptance criteria in T237595.

Niharika closed this task as Resolved.Jun 3 2020, 3:45 AM