Page MenuHomePhabricator

[Bug] mobile-html and summary (possibly other) endpoints not getting updated after edits
Closed, ResolvedPublic

Description

Steps to Reproduce

  1. Edit a page or a wikidata description
  2. Wait 5 seconds
  3. Load the /page/summary or /page/mobile-html for that page or the page associated with that wikidata item

Expected Results

The /page/summary and /page/mobile-html response are updated

Actual Results

The /page/summary and /page/mobile-html response are out of date and seem to not be updated at all

Notes

One of the pages I am testing with is https://test.wikipedia.org/api/rest_v1/page/mobile-html/Aaaaaaaaaa - the content does not match https://test.wikipedia.org/wiki/Aaaaaaaaaa

The summary is also incorrect: https://test.wikipedia.org/api/rest_v1/page/summary/Aaaaaaaaaa

I tested with other pages and other wikis as well, same problem

Event Timeline

JoeWalsh created this task.May 7 2020, 6:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 7 2020, 6:03 PM
JoeWalsh triaged this task as Unbreak Now! priority.May 7 2020, 6:03 PM
Restricted Application added subscribers: Liuxinyu970226, Mholloway. · View Herald TranscriptMay 7 2020, 6:03 PM
JoeWalsh updated the task description. (Show Details)May 7 2020, 6:05 PM
Mholloway added a subscriber: Pchelolo.

Any such problem will really be in ChangeProp and/or RESTBase, so tagging those projects (and @Pchelolo who knows most about them).

JoeWalsh updated the task description. (Show Details)May 7 2020, 6:07 PM

I know what's going on. That's me and @hnowlan breaking things. Will fix right away.

Pchelolo claimed this task.May 7 2020, 6:10 PM

Change 595013 had a related patch set uploaded (by Ppchelko; owner: Ppchelko):
[mediawiki/services/change-propagation/deploy@master] Enable both resource-purge and resource-change purges

https://gerrit.wikimedia.org/r/595013

Change 595013 merged by Ppchelko:
[mediawiki/services/change-propagation/deploy@master] Enable both resource-purge and resource-change purges

https://gerrit.wikimedia.org/r/595013

Change 595016 had a related patch set uploaded (by Ppchelko; owner: Ppchelko):
[mediawiki/services/change-propagation/deploy@master] Rename rule following resource-purge

https://gerrit.wikimedia.org/r/595016

Change 595016 merged by Ppchelko:
[mediawiki/services/change-propagation/deploy@master] Rename rule following resource-purge

https://gerrit.wikimedia.org/r/595016

Mentioned in SAL (#wikimedia-operations) [2020-05-07T18:23:46Z] <ppchelko@deploy1001> Started deploy [changeprop/deploy@383fba5]: Enable both purging types T252142

Mentioned in SAL (#wikimedia-operations) [2020-05-07T18:25:03Z] <ppchelko@deploy1001> Finished deploy [changeprop/deploy@383fba5]: Enable both purging types T252142 (duration: 01m 17s)

@JoeWalsh should be fixed now. Our sincere apologies, we are going to be done messing with this soon.

Please give it about 10-20 minutes before verifying, it needs to catch up on the backlog

Tested again. The content is ok after edits.

For future reporting of issues like this, it's always interesting if the effect you observe at the time of reporting is Varnish-related or RESTBase-related. To check for that, you could supply some bogus query string like ?a=b to the request, and see if it fixed the issue. If you get correct result - Varnish is the problem.

I'm asking the reporter to do that since time is critical here - what was true at the time of reporting might not be true 10 minutes later when I look at the bug.

Pchelolo closed this task as Resolved.May 8 2020, 2:01 PM