Page MenuHomePhabricator

Discussion Tools returning invalid response from server on nlwiki specific user talk page
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
Hit reply ('Reageer') on
https://nl.wikipedia.org/wiki/Overleg_gebruiker:Romaine

Actual Results:
A message pops up with 'Invalid response from server' ('Ongeldige reactie van de server ontvangen')

Expected Results:
An input box to enter a reply

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2020, 7:06 PM
RhinosF1 renamed this task from Invalid response from server error message using reply tool on user talk page to Discussion Tools returning invalid response from server on nlwiki user talk pages.May 8 2020, 7:29 PM
RhinosF1 added a project: OWC2020.
RhinosF1 removed a subscriber: OWC2020.
Restricted Application added a subscriber: RhinosF1. · View Herald TranscriptMay 8 2020, 7:29 PM

@AdHuikeshoven: I can only reproduce this on nlwiki user talk pages, is that correct for you?

Yes, I have only seen this response on this specific user page.

matmarex claimed this task.May 8 2020, 9:59 PM
matmarex added a subscriber: matmarex.

This is actually caused by an exception, the error message is wrong:

TypeError: section.firstChild.setAttribute is not a function
    at <anonymous>:393:25306
    at NodeList.forEach (<anonymous>)
    at Object.mw.libs.ve.unwrapParsoidSections (<anonymous>:393:25105)
...

Apparently section.firstChild is this case is a comment node

ppelberg added a subscriber: ppelberg.

Change 595589 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Show real error message when an exception is thrown

https://gerrit.wikimedia.org/r/595589

Change 595590 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Fix #unwrapParsoidSections for pseudo-sections (generated by templates)

https://gerrit.wikimedia.org/r/595590

matmarex renamed this task from Discussion Tools returning invalid response from server on nlwiki user talk pages to Discussion Tools returning invalid response from server on nlwiki specific user talk page.May 11 2020, 9:14 PM

Change 597137 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] CommentUtils: Fix unwrapParsoidSections() for pseudo-sections (generated by templates)

https://gerrit.wikimedia.org/r/597137

Change 595590 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix #unwrapParsoidSections for pseudo-sections (generated by templates)

https://gerrit.wikimedia.org/r/595590

Change 595589 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Show real error message when an exception is thrown

https://gerrit.wikimedia.org/r/595589

Change 597137 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Add test case for unwrapParsoidSections()

https://gerrit.wikimedia.org/r/597137

Reply works on said user page. Ticket can be closed.

ppelberg closed this task as Resolved.Jun 1 2020, 1:31 AM