Page MenuHomePhabricator

Reply button stays disabled for the entire session, if you just cancel replying for once
Closed, ResolvedPublic

Description

Steps to replicate:

  1. Open a talk page.
  2. Click on "Reply" link.
  3. Click "Cancel".
  4. Now again click on Reply link.
  5. This time type something in the Reply box.

Observed Result:

The "Reply" button stays disabled. This happens incase of both Source and Visual mode regardless of whether you typed something before clicking on "Cancel" button.

Browser:Chrome.
Environment: Beta.

Event Timeline

Ryasmeen created this task.May 11 2020, 6:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2020, 6:29 PM

Notes:

  • You can stll submit with Ctrl+Enter
  • Only the comment you cancelled on is affected, the reply buttons for other comments work fine

This is caused by this.replyBodyWidget.off( 'change' ); in ReplyWidgetPlain#teardown and ReplyWidgetVisual#teardown. @Esanders I am not sure what this was for. Is it supposed to only remove the onFirstTransaction handler?

Yeah, we should probably just move all the event bindings to setup.

Change 596878 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] ReplyWidget: Move all events bind to setup

https://gerrit.wikimedia.org/r/596878

Esanders triaged this task as High priority.May 17 2020, 8:13 PM

Change 596878 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] ReplyWidget: Move all events bind to setup

https://gerrit.wikimedia.org/r/596878

Ryasmeen edited projects, added Verified; removed Editing QA.
ppelberg closed this task as Resolved.May 21 2020, 11:33 PM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 21 2020, 11:33 PM