Page MenuHomePhabricator

Regression: Plain text sidebar section stopped working in Vector
Closed, ResolvedPublic

Description

I can confirm this works as expected on group2/wmf.31 but is broken on wmf.32. Also it still works in all versions under MonoBook, which suggests it is a bug in Vector that was introduced in the new branch.

Issue on https://www.mediawiki.org/

Vector (wmf.32)MonoBook (wmf.31)Vector (wmf.31)

Issue on https://wikitech.wikimedia.org/

(wmf.32)

Event Timeline

Krinkle created this task.May 13 2020, 11:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2020, 11:31 PM
Krinkle added a comment.EditedMay 13 2020, 11:33 PM

Impact is fairly minimal, so assuming it gets fixed by next week it perhaps need not block the train (ref T249964).

Krinkle updated the task description. (Show Details)EditedMay 14 2020, 12:22 AM

The issue is spotted on wikitech.wikimedia.org as well. It is failing to fallback to plain text, but also wrongly double-escapes the label:

Change 596465 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/Vector@master] Allow plain text labels in side bar

https://gerrit.wikimedia.org/r/596465

Jdlrobson renamed this task from Plain text sidebar section stopped working in Vector to Regression: Plain text sidebar section stopped working in Vector.May 14 2020, 3:24 PM

Change 596465 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Allow plain text labels in side bar

https://gerrit.wikimedia.org/r/596465

hashar triaged this task as Unbreak Now! priority.May 14 2020, 7:43 PM
hashar added a subscriber: hashar.

Train blockers are unbreak now.

It seems it is all about deploying https://gerrit.wikimedia.org/r/#/c/mediawiki/skins/Vector/+/596465/ to 1.35.0-wmf.32

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 14 2020, 7:43 PM

Change 596503 had a related patch set uploaded (by Hashar; owner: Jdlrobson):
[mediawiki/skins/Vector@wmf/1.35.0-wmf.32] Allow plain text labels in side bar

https://gerrit.wikimedia.org/r/596503

I am going to hot deploy it.

Change 596503 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.35.0-wmf.32] Allow plain text labels in side bar

https://gerrit.wikimedia.org/r/596503

@matmarex helped with the deployment. The bug on mediawiki.org got worked around by creating a dummy page https://www.mediawiki.org/w/index.php?title=MediaWiki:MediaWiki.org . I have deleted it and that indeed confirmed the issue is fixed.

Impact is fairly minimal, so assuming it gets fixed by next week it perhaps need not block the train (ref T249964).

I added it as a blocker because I think it looks really silly, and because the sidebar is cached in funny ways, so it could be a while before the fix takes effect. (And we've actually just spent a good few minutes with @hashar trying to confirm whether it worked, because things were cached.)

Mentioned in SAL (#wikimedia-operations) [2020-05-14T20:15:25Z] <hashar@deploy1001> Synchronized php-1.35.0-wmf.32/skins/Vector/includes/VectorTemplate.php: Allow plain text labels in side bar - T252727 (duration: 01m 06s)

hashar closed this task as Resolved.May 14 2020, 8:19 PM

https://wikitech.wikimedia.org/ sidebar eventually got fixed a couple minutes or so after I have deployed.

Thank you @matmarex for all the assistance!

Thanks @matmarex and @hashar for SWATing this.