Page MenuHomePhabricator

Issue: Broken RTL experience article flow
Closed, InvalidPublicBUG REPORT

Description

Steps to reproduce

  1. Change phone language in phone settings to Urdu
  2. Launch Wikipedia app
  3. Type a search
  4. Switch languages through the settings menu

Actual results

It is possible to search for and read articles in Urdu, but the experience is broken since we do not yet fully support RTL languages

Expected results

App defaults to English when a user's phone is RTL, and users can choose from a list of LTR languages.

Event Timeline

AMuigai created this task.May 14 2020, 8:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 14 2020, 8:11 PM
AMuigai triaged this task as Medium priority.May 14 2020, 8:17 PM
AMuigai moved this task from Bugs to Next up on the Inuka-Team board.May 14 2020, 8:29 PM
AMuigai changed the subtype of this task from "Task" to "Bug Report".May 14 2020, 8:42 PM
AMuigai renamed this task from Issue: RTL for Urdu to Issue: Broken RTL experience article flow.May 19 2020, 8:30 PM
AMuigai closed this task as Invalid.May 21 2020, 12:42 PM