Page MenuHomePhabricator

"A LocalSettings.php file has been detected. To upgrade this installation, please run update.php instead" output twice
Open, Needs TriagePublic

Description

Running install.php when a LocalSettings.php file already exists...

PHP 7.3.11-0ubuntu0.19.10.4 is installed.
Found ImageMagick: /usr/bin/convert. Image thumbnailing will be enabled if you enable uploads.
Found the Git version control software: /usr/bin/git.
Using server name "http://localhost".
Using server URL "http://127.0.0.1:9412".
Warning: Your default directory for uploads (/var/www/wiki/mediawiki/core/images/) is not checked for vulnerability to arbitrary script execution during the CLI install.
Using the PHP intl extension for Unicode normalization.
The environment has been checked. You can install MediaWiki.
A LocalSettings.php file has been detected. To upgrade this installation, please run update.php instead
A LocalSettings.php file has been detected. To upgrade this installation, please run update.php instead

A LocalSettings.php file has been detected. To upgrade this installation, please run update.php instead

is output twice

Event Timeline

Reedy created this task.May 21 2020, 7:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 21 2020, 7:55 PM

Change 597917 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/core@master] Don't show duplicate error/warning message on CLI install

https://gerrit.wikimedia.org/r/597917

Ammarpad claimed this task.May 23 2020, 7:41 AM
Peachey88 moved this task from General to CLI on the MediaWiki-Installer board.Sun, Nov 22, 4:04 AM
Ammarpad removed Ammarpad as the assignee of this task.Tue, Nov 24, 5:18 AM
Ammarpad added a subscriber: Ammarpad.

Change 597917 abandoned by Ammarpad:
[mediawiki/core@master] Don't show duplicate error/warning message on CLI install

Reason:

https://gerrit.wikimedia.org/r/597917