Page MenuHomePhabricator

Not switching to mobile version by default on smartphone
Closed, DeclinedPublic

Description

Earlier, it redirected to m.wikipedia whenever we opened any wikipedia page on smartphone unless desktop version was opted for. Now it just shows whichever we are looking unaffected by our choice of desktop/mobile version in browser.

When you open wikipedia.org from mobile chrome browser, it opens the following page

Screenshot_20200523-215803.png (1×1 px, 957 KB)

This even when browser setting was not set to desktop version. See
Screenshot_20200523-215810.png (1×1 px, 356 KB)

In case of mobile version, it should have redirected to m.wikipedia.org and should have opened this

Screenshot_20200523-220553.png (1×1 px, 483 KB)

Further, switching to and from desktop version doesn't change url between m.wikipedia.org and wikipedia.org, which it should have
See this is desktop version, even when url was m.wikipedia.org

Screenshot_20200523-220601.png (1×1 px, 450 KB)

Screenshot_20200523-220607.png (1×1 px, 260 KB)

Event Timeline

At the bottom of the page, you can toggle between desktop or mobile view, see if that helps. I think this used to be a recurring issue with MobileFrontend before? But I can't be too sure.

Aklapper changed the task status from Open to Stalled.May 23 2020, 4:24 PM

Hi @Capankajsmilyo, thanks for taking the time to report this! Unfortunately this Wikimedia Phabricator task lacks some information.
If you have time and can still reproduce the situation: Please add a more complete description to this task. That should be

  • a clear list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen,
  • which browser and operating system and operating system version you are using.

You can edit the task description by clicking Edit Task. Ideally, a good description should allow any other person to follow these steps (without having to interpret steps) and see the same results. Problems that others can reproduce can get fixed faster. Thanks again!

Jdlrobson added a subscriber: Jdlrobson.

When you clear your cookies for the site does this problem go away?

This even when browser setting was not set to desktop version.

Yeh this is a separate bug. The "use desktop" directive doesn't work with our setup. That just turns off media queries.

When you clear your cookies for the site does this problem go away?

@Capankajsmilyo: Could you please answer the last comment? Thanks in advance!

Unfortunately closing this Phabricator task as no further information has been provided.

@Capankajsmilyo: After you have provided the information asked for and if this still happens, please set the status of this task back to "Open" via the Add Action...Change Status dropdown. Thanks!

Note: this is likely the longstanding bug T60425 which this would be a duplicate of.