Page MenuHomePhabricator

Issue with the display text in links to redirected pages (due to Display Title extension)
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

Actual Results:
Since an user upgraded his wiki to 1.34.1, all the internal links to redirection pages are showing the link page title (with namespace) and not the selected text. i.e., if we have a link like this: <nowiki>[[tempate:redirected page|some text]]</nowiki> we will see a link text of "template:redirected page" instead of "some text".

See https://www.mediawiki.org/wiki/Topic:Vn0gf7kok5o0owel

Expected Results:

Event Timeline

SVG created this task.May 25 2020, 1:06 PM
Restricted Application added subscribers: Liuxinyu970226, jeblad, Aklapper. · View Herald TranscriptMay 25 2020, 1:06 PM
Aklapper changed the task status from Open to Stalled.May 25 2020, 1:43 PM
Aklapper removed a project: MW-1.34-release.

Hi @SVG, thanks for taking the time to report this! Unfortunately this Wikimedia Phabricator task lacks some information.
If you have time and can still reproduce the situation: Please add a more complete description to this task. That should be

  • a clear list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen.

In some situations it can also be helpful to know if you see the same behavior when you are not logged in, your web browser(s) and web browser version(s), your exact MediaWiki version (if it is not on a Wikimedia wiki) and PHP version, etc.

You can edit the task description by clicking Edit Task. Ideally, a good description should allow any other person to follow these steps (without having to interpret steps) and see the same results. Problems that others can reproduce can get fixed faster. Thanks!

Please also list the extensions you have installed.

It's not the first time someone comes with a similar problem caused by Extension:Display Title

Wess added a subscriber: Wess.May 25 2020, 3:53 PM

Hey @Ciencia_Al_Poder
Looks like the issue is indeed related to the Display Title Extension and was fixed after disabling the extension.
Thanks for that!

Aklapper renamed this task from Issue with the display text in links to redirected pages to Issue with the display text in links to redirected pages (due to Display Title extension).May 25 2020, 4:14 PM
Aklapper closed this task as Invalid.
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMay 25 2020, 4:14 PM