Page MenuHomePhabricator

Rename some es.wikipedia namespaces
Closed, ResolvedPublic

Description

The Spanish Wikipedia through a discussion would like that the namespaces Anexo_Discusión, Portal_Discusión and Wikiproyecto_Discusión be renamed so Discusión becomes discusión as it happens with all other NS_*_TALK namespaces for Spanish for Core and Extensions.

Current config
	'eswiki' => [
		100 => 'Portal',
		101 => 'Portal_Discusión',
		102 => 'Wikiproyecto',
		103 => 'Wikiproyecto_Discusión',
		104 => 'Anexo', // T11304
		105 => 'Anexo_Discusión',
	],
Requested config
	'eswiki' => [
		100 => 'Portal',
		101 => 'Portal_discusión',
		102 => 'Wikiproyecto',
		103 => 'Wikiproyecto_discusión',
		104 => 'Anexo', // T11304
		105 => 'Anexo_discusión',
	],

Case-only change but I guess namespaceDupes.php will need to be run afterwards?

Self-assigned. I'll try to get it deployed next week.

Event Timeline

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptMay 30 2020, 6:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
MarcoAurelio triaged this task as Lowest priority.May 30 2020, 6:56 PM
MarcoAurelio moved this task from Backlog to Working on on the Wikimedia-Site-requests board.

Change 600979 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[operations/mediawiki-config@master] [eswiki] Normalize talk namespaces for Anexo, Portal and Wikiproyecto

https://gerrit.wikimedia.org/r/600979

Change 600979 merged by jenkins-bot:
[operations/mediawiki-config@master] [eswiki] Normalize talk namespaces for Anexo, Portal and Wikiproyecto

https://gerrit.wikimedia.org/r/600979

Mentioned in SAL (#wikimedia-operations) [2020-06-03T11:26:52Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:600979|[eswiki] Normalize talk namespaces for Anexo, Portal and Wikiproyecto (T254077)]] (duration: 01m 03s)

Mentioned in SAL (#wikimedia-operations) [2020-06-03T11:29:29Z] <Lucas_WMDE> lucaswerkmeister-wmde@mwmaint1002:~$ mwscript namespaceDupes.php eswiki | tee T254077.dry-run

Mentioned in SAL (#wikimedia-operations) [2020-06-03T11:29:29Z] <Lucas_WMDE> lucaswerkmeister-wmde@mwmaint1002:~$ mwscript namespaceDupes.php eswiki | tee T254077.dry-run

output
0 pages to fix, 0 were resolvable.

pagelinks from=145052 ns=0 dbk=Media: *** INVALID
1 links to fix, 0 were resolvable, 0 were deleted.

Looks good!

Not sure what to make of this, to be honest…

Mentioned in SAL (#wikimedia-operations) [2020-06-03T11:30:46Z] <Lucas_WMDE> lucaswerkmeister-wmde@mwmaint1002:~$ mwscript namespaceDupes.php eswiki --fix | tee T254077.fix

Mentioned in SAL (#wikimedia-operations) [2020-06-03T11:30:46Z] <Lucas_WMDE> lucaswerkmeister-wmde@mwmaint1002:~$ mwscript namespaceDupes.php eswiki --fix | tee T254077.fix

output
0 pages to fix, 0 were resolvable.

pagelinks from=145052 ns=0 dbk=Media: *** INVALID
1 links to fix, 0 were resolvable, 0 were deleted.

Looks good!
MarcoAurelio closed this task as Resolved.Jun 3 2020, 12:14 PM
MarcoAurelio moved this task from Working on to To deploy on the Wikimedia-Site-requests board.

Thank you!

“pagelinks from=145052” presumably refers to https://es.wikipedia.org/w/index.php?curid=145052, but I don’t see anything suspicious on that page.

OTOH @Reedy Didn't we fixed pagelinks from=145052 ns=0 dbk=Media: *** INVALID already in T251562#6099943 ? Why is that link back?

Reedy added a comment.Jun 3 2020, 12:18 PM

Based on my comment and the output, yeah. Something is obviously re-inserting it...

Yeah, something’s strange on that page:

wikiadmin@10.64.48.109(eswiki)> SELECT * FROM pagelinks WHERE pl_from = 145052;
+---------+--------------+--------------------------------------+-------------------+
| pl_from | pl_namespace | pl_title                             | pl_from_namespace |
+---------+--------------+--------------------------------------+-------------------+
|  145052 |            0 | Departamentos_de_Francia             |                14 |
|  145052 |            0 | Francia                              |                14 |
|  145052 |            0 | Guadalupe_(Francia)                  |                14 |
|  145052 |            0 | Guayana_Francesa                     |                14 |
|  145052 |            0 | Martinica                            |                14 |
|  145052 |            0 | Media:                               |                14 |
|  145052 |            0 | Organización_territorial_de_Francia  |                14 |
|  145052 |            0 | Reunión_(departamento_de_Francia)    |                14 |
|  145052 |            0 | Wikimedia_Commons                    |                14 |
|  145052 |           12 | Categoría                            |                14 |
|  145052 |          100 | Francia                              |                14 |
+---------+--------------+--------------------------------------+-------------------+
11 rows in set (0.00 sec)

I assume it’s from this part in the wikitext:

{{metaplantilla de avisos
| tipo  = información
| imagen =
 # [[Archivo:Info non-talk.png|30px]] 
 # | texto 
 = [[Archivo:Départements de France-simple.svg|left|50px]] <center>Esta [[Ayuda:Categoría|categoría]] es un contenedor utilizado para organizar las categorías de los '''[[departamentos de Francia]]''', entidades administrativas de segundo nivel de la [[organización territorial de Francia]].</br>Francia tiene 100 departamentos (4 de ellos de ultramar: [[Guadalupe (Francia)|Guadalupe]], [[Guayana Francesa]], [[Martinica]] y [[Reunión (departamento de Francia)|Reunión]]).
}}

That second imagen line looks suspicious, and from the pagelinks I assume that the template turns it into a [[Media:]] sitelink. But anyways, that shouldn’t be a problem as far as this task is concerned, just a general (very minor) oddity of the pagelinks table of that wiki.

@Lucas_Werkmeister_WMDE & @Reedy https://es.wikipedia.org/w/index.php?title=Plantilla:Aviso&action=edit uses Media: in a link. Maybe switching that one to Archivo: would prevent this broken link from reapearing?

I think the problem is the empty part after the namespace name, not whether the namespace name is Media or Archivo.

I (as a volunteer) reverted the edit to that page which had introduced the odd wikitext, and which I think was simply vandalism (another edit by the same IP was also obvious vandalism) –

– and that seems to have fixed the odd pagelinks row, and namespaceDupes.php no longer prints any notices.

Thanks again, all.