Page MenuHomePhabricator

1.35.0-wmf.38 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.35.0-wmf.38
Release Date
1592784000
Backup Conductor
hashar

2020 week 26 1.35-wmf.38 Changes wmf/1.35.0-wmf.38

This MediaWiki Train Deployment is scheduled for the week of Monday, June 22nd:

Monday June 22ndTuesday, June 23rdWednesday, June 24thThursday, June 25thFriday
Backports only.Branch wmf.38 and deploy to Group 0 Wikis.Deploy wmf.38 to Group 1 Wikis.Deploy wmf.38 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.38 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.35.0-wmf.37
Next: 1.35.0-wmf.39

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2020, 4:11 PM
thcipriani triaged this task as Medium priority.
thcipriani updated Backup Conductor, added: hashar.
brennen moved this task from Backlog to Next on the User-brennen board.

Just adding a quick note, that cpt has moved some mediawiki REST endpoints from /v0 namespace into /v1 (https://gerrit.wikimedia.org/r/c/mediawiki/core/+/604441). This shouldn't be a problem but just making a note of it.

daniel added a subscriber: daniel.Tue, Jun 16, 9:12 PM

Just adding a quick note, that cpt has moved some mediawiki REST endpoints from /v0 namespace into /v1 (https://gerrit.wikimedia.org/r/c/mediawiki/core/+/604441). This shouldn't be a problem but just making a note of it.

To be clear, moving the endpoints to v1 means enabling them on all sites. v0 is only enabled on test and beta. The new batch of endpoints going live for the first time include endpoints that allow page edits via PUT and POST. We are not expecting much traffic on the new endpoints yet.

Change 607158 had a related patch set uploaded (by DannyS712; owner: trainbranchbot):
[mediawiki/core@wmf/1.35.0-wmf.38] Branch commit for wmf/1.35.0-wmf.38

https://gerrit.wikimedia.org/r/607158

brennen moved this task from Next to In Progress on the User-brennen board.Tue, Jun 23, 3:49 AM

I'll merge branch cut and start testwiki sync process in ~18 minutes at 10:00 MDT / 16:00 UTC.

Change 607158 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.38] Branch commit for wmf/1.35.0-wmf.38

https://gerrit.wikimedia.org/r/607158

Will do a scap sync at local start-of-workday for T256151 - see T256151#6250427 for details.

Mentioned in SAL (#wikimedia-operations) [2020-06-24T19:01:38Z] <brennen> train 1.35.0-wmf.38: finished triage meeting, clear to proceed to group 1 (T254175)

Mentioned in SAL (#wikimedia-operations) [2020-06-24T20:41:22Z] <brennen> train 1.35.0-wmf.38: attempting to roll forward to group1 after php-fpm restart on mw1287 (T256305, T254175)

brennen closed this task as Resolved.Fri, Jun 26, 5:35 PM
brennen moved this task from In Progress to Done / Defunct on the User-brennen board.

Deployed to all wikis yesterday, seems to have stuck. Calling this resolved for the week.

Deployed to all wikis yesterday, seems to have stuck. Calling this resolved for the week.

Note that T256526: Items from watchlist no longer highlighted at Special:RecentChangesLinked may have been caused by the train