Page MenuHomePhabricator

Special:MediaSearch shows duplicate results for some queries
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

When running a search at Special:MediaSearch that returns a small number of hits, I'm able to see duplicate result items for some searches. Instead of seeing 2 items, I see 4 (each item appears twice). This only happens when JS is enabled, so the duplication does not appear to be happening server-side.

Actual Results:

These results are the expected ones for the given query, but they each appear twice on the page.

Expected Results:

Each result should only appear once.

Event Timeline

egardner created this task.Jun 1 2020, 5:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2020, 5:54 PM

Looks like this might come from the hasMore property defaulting to true in some places – should we default to false instead?

CBogen added a subscriber: CBogen.Jun 10 2020, 4:22 PM

This is blocked until T252685 is complete, which may resolve this issue. If not, we want to solve it using the new CirrusSearch backend.

Change 610286 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Fix duplicate rendering of initial small batch of results

https://gerrit.wikimedia.org/r/610286

Change 610286 merged by Matthias Mullie:
[mediawiki/extensions/WikibaseMediaInfo@master] Fix duplicate rendering of initial small batch of results

https://gerrit.wikimedia.org/r/610286

Ramsey-WMF added a subscriber: Ramsey-WMF.

should be testable on production now

Etonkovidova closed this task as Resolved.Jul 24 2020, 8:46 PM

Checked on commons wmf.1 - the issue is fixed. Sometime it seems as though the duplicate images are present when, in fact, there different variations of a file/image, e.g.: