Page MenuHomePhabricator

SpecialUserrights.php: Call to undefined method CentralAuthGroupMembershipProxy::canReceiveEmail()
Closed, ResolvedPublic

Description

Error message
[Xtg5GqwQBHcAAB1nC4kAAABP] /wiki/Special:GlobalUserRights/DannyS712 Error from line 716 of /srv/mediawiki/php-master/includes/specials/SpecialUserrights.php: Call to undefined method CentralAuthGroupMembershipProxy::canReceiveEmail()
Stack Trace
Backtrace:

#0 /srv/mediawiki/php-master/includes/specials/SpecialUserrights.php(506): UserrightsPage->showEditUserGroupsForm(CentralAuthGroupMembershipProxy, array, array)
#1 /srv/mediawiki/php-master/includes/specials/SpecialUserrights.php(227): UserrightsPage->editUserGroupsForm(string)
#2 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(580): UserrightsPage->execute(string)
#3 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(634): SpecialPage->run(string)
#4 /srv/mediawiki/php-master/includes/MediaWiki.php(307): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#5 /srv/mediawiki/php-master/includes/MediaWiki.php(986): MediaWiki->performRequest()
#6 /srv/mediawiki/php-master/includes/MediaWiki.php(543): MediaWiki->main()
#7 /srv/mediawiki/php-master/index.php(47): MediaWiki->run()
#8 /srv/mediawiki/w/index.php(3): require(string)
#9 {main}
Impact

Unable to use Special:GlobalUserRights

Notes

Caused by T251534: Special:UserRights shows "send email" for user without valid email
Stack trace is for beta cluster, but also exists in production - error code 71202776-036d-43b1-8e99-dce1c5a2fe72

Details

Request ID
Xtg5GqwQBHcAAB1nC4kAAABP
Request URL
https://deployment.wikimedia.beta.wmflabs.org/wiki/Special:GlobalUserRights/DannyS712
Stack Trace

Backtrace:

#0 /srv/mediawiki/php-master/includes/specials/SpecialUserrights.php(506): UserrightsPage->showEditUserGroupsForm(CentralAuthGroupMembershipProxy, array, array)
#1 /srv/mediawiki/php-master/includes/specials/SpecialUserrights.php(227): UserrightsPage->editUserGroupsForm(string)
#2 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(580): UserrightsPage->execute(string)
#3 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(634): SpecialPage->run(string)
#4 /srv/mediawiki/php-master/includes/MediaWiki.php(307): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#5 /srv/mediawiki/php-master/includes/MediaWiki.php(986): MediaWiki->performRequest()
#6 /srv/mediawiki/php-master/includes/MediaWiki.php(543): MediaWiki->main()
#7 /srv/mediawiki/php-master/index.php(47): MediaWiki->run()
#8 /srv/mediawiki/w/index.php(3): require(string)
#9 {main}

Event Timeline

Restricted Application added a project: User-DannyS712. · View Herald TranscriptJun 4 2020, 12:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
DannyS712 triaged this task as Unbreak Now! priority.
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 4 2020, 12:02 AM

Change 602196 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/core@master] Revert "Don't show email link if the user cannot be emailed."

https://gerrit.wikimedia.org/r/602196

Change 602198 had a related patch set uploaded (by Reedy; owner: DannyS712):
[mediawiki/core@wmf/1.35.0-wmf.35] Revert "Don't show email link if the user cannot be emailed."

https://gerrit.wikimedia.org/r/602198

Change 602196 merged by jenkins-bot:
[mediawiki/core@master] Revert "Don't show email link if the user cannot be emailed."

https://gerrit.wikimedia.org/r/602196

Change 602198 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.35] Revert "Don't show email link if the user cannot be emailed."

https://gerrit.wikimedia.org/r/602198

Mentioned in SAL (#wikimedia-operations) [2020-06-04T00:36:01Z] <reedy@deploy1001> Synchronized php-1.35.0-wmf.35/includes/specials/SpecialUserrights.php: T254417 T251534 (duration: 01m 06s)

Reedy closed this task as Resolved.Jun 4 2020, 12:36 AM
DannyS712 moved this task from Unsorted to Merged on the User-DannyS712 board.Thu, Jul 9, 11:18 PM