Page MenuHomePhabricator

Regression: Tool "User uploads" in the sidebar missing in skin Monobook
Closed, ResolvedPublic

Description

The tool "User uploads" in the sidebar missing in skin Monobook (at least) since the last deployment train. In Vector the link is still there.

Steps to reproduce :

Event Timeline

Raymond created this task.Jun 5 2020, 6:10 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 5 2020, 6:10 AM
Ammarpad claimed this task.Jun 5 2020, 7:00 AM
Ammarpad triaged this task as Medium priority.
Ammarpad removed a project: Platform Engineering.

Change 602612 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/UploadsLink@master] UploadsLink: Use SidebarBeforeOutput hook to add toolbox item

https://gerrit.wikimedia.org/r/602612

Wurgl added a subscriber: Wurgl.Jun 5 2020, 10:28 AM

Maybe related: Link to Wikidata-Object is missing too (only in MonoBook, all other skins I tried show that link)

Jdlrobson renamed this task from Tool "User uploads" in the sidebar missing in skin Monobook to Regression: Tool "User uploads" in the sidebar missing in skin Monobook.Jun 5 2020, 4:12 PM

Change 602612 merged by jenkins-bot:
[mediawiki/extensions/UploadsLink@master] UploadsLink: Use SidebarBeforeOutput hook to add toolbox item

https://gerrit.wikimedia.org/r/602612

Jdlrobson closed this task as Resolved.Jun 5 2020, 4:22 PM
Jdlrobson added a subscriber: Jdlrobson.

Hey @Raymond this should be fixed in the next train. Sorry about that. We're making some technical changes to simplify the menu code and sadly I missed this one in code review.

The fix for this will roll out in next week's train but the patch can be SWATTed to 1.35.0-wmf.35 if it's needed sooner (https://wikitech.wikimedia.org/wiki/Deployments)

Maybe related: Link to Wikidata-Object is missing too (only in MonoBook, all other skins I tried show that link)

Have captured this in T254485

Hey @Raymond this should be fixed in the next train. Sorry about that. We're making some technical changes to simplify the menu code and sadly I missed this one in code review.

The fix for this will roll out in next week's train but the patch can be SWATTed to 1.35.0-wmf.35 if it's needed sooner (https://wikitech.wikimedia.org/wiki/Deployments)

Thank you, @Jdlrobson. I think deployment with the next train is fine.

Thanks for flagging it. Please do let me know if you see anything else strange in menus over the course of this month after which we should be back to a place of stability :)

Strangely this is still not working

I'm also not seeing this link on the beta cluster:
https://commons.wikimedia.beta.wmflabs.org/wiki/User:Selenium_user
We'll continue exploring in T255444 as this now impacts Vector AND Monobook