Page MenuHomePhabricator

Remove XCache from mediawiki.org documentation pages
Closed, ResolvedPublic

Event Timeline

Aklapper created this task.Jun 7 2020, 6:43 AM
Annysah01 claimed this task.EditedOct 8 2020, 2:28 PM

Hello @Aklapper, I would love to work on this issue.

@Annysah01: Welcome and thanks!

Note that translated (non-English) pages should not be changed, and that historical information (for example ChangeLogs or Release Notes of published MediaWiki versions) should not be changed either.
That leaves us with seven pages from this list: https://www.mediawiki.org/w/index.php?title=Special:Search&limit=500&offset=0&ns12=1&ns100=1&search=xcache

@Aklapper Just wanted to confirm, do we need to remove the mention of XCache from those 7 pages altogether? Or can we add a note about deprication like in https://www.mediawiki.org/w/index.php?title=Manual%3A%24wgMessageCacheType&type=revision&diff=3975320&oldid=3751023 to the ~3 pages that don't have the note?

@Annysah01 Here is a reference on editing pages: https://www.mediawiki.org/wiki/Help:Editing_pages :)

Good question, thanks! :) I would probably go conservative and consistently add {{removed-inline|1.31}} to those pages, as I just realized that https://www.mediawiki.org/wiki/Template:Removed-inline exists.

@Pavithraes @Aklapper I am a little bit confused as to what do, where to edit the docs and record changes made, please i need help. Thanks in anticipation

Annysah01 added a comment.EditedOct 11 2020, 12:29 PM

I have been able to figure it out with the links and instructions sent earlier on. Thank you!

@Annysah01: Hi, I see you made some first edits on mediawiki.org, congratulations! Could you please check the page preview before saving? It seems that the word "XCache" was removed, so now the content isn't self-explanatory... for example it says (removed in 1.31) support was removed. Could you fix that?
Also, you could add (see [[phab:T254681]]) to your edit summaries so anyone looking at the history of a page can get some more context. Thanks! :)

Hello @Aklapper , do you mean that after I remove the XCache, I should not add {{removed-inline|1.31}} and then make it blank right?

This comment was removed by Annysah01.

@Aklapper I have made changes to 5 out of 7

https://www.mediawiki.org/wiki/Manual:$wgObjectCaches - should I remove the XCache in the codes of this page?

https://www.mediawiki.org/wiki/Manual:Config_script - This particular page says the doc is outdated, which is restricting the access to edit.

@Annysah01: Hi, it looks like Kghbln made followup edits on three out of the five pages that you edited, and they should be fine now.

The other two pages that were edited at https://www.mediawiki.org/wiki/Manual:$wgParserCacheType and https://www.mediawiki.org/wiki/Manual:Caching still need more fixes for the previous edits: XCache should not simply be replaced with {{removed-inline|1.31}}.
Please first check the page preview and the resulting content, before saving any edits.

https://www.mediawiki.org/wiki/Manual:$wgObjectCaches - should I remove the XCache in the codes of this page?

XCache was only removed in MediaWiki version 1.31. In MediaWiki version 1.30 and earlier, XCache was supported and a valid option that should stay.
For the sections on that wiki page, please thoroughly check the MediaWiki version: ≥ 1.something info for each section, and decide based on that.

https://www.mediawiki.org/wiki/Manual:Config_script - This particular page says the doc is outdated, which is restricting the access to edit.

It says This page has been protected so that only autoconfirmed users can edit it, so it is unrelated that it is outdated... you cannot edit it because you are not (yet) an autoconfirmed user.
I've made that edit now. See the text changes and edit summary in https://www.mediawiki.org/w/index.php?title=Manual:Config_script&type=revision&diff=4167214&oldid=4025090 if you're curious. Thanks! :)

Hello @Aklapper,
I made the corrections to the pages you mentioned yesterday.

@Annysah01: Thanks! :) I added a small typofix in https://www.mediawiki.org/w/index.php?title=Manual:$wgParserCacheType&type=revision&diff=4169759&oldid=4167670 (there was a whitespace in front of a comma).

I think that means that the only item left is checking if https://www.mediawiki.org/wiki/Manual:$wgObjectCaches needs any changes?

Aklapper closed this task as Resolved.Oct 15 2020, 10:48 AM

Looks like all work needed has been done, so I am resolving this task. @Annysah01: Congratulations and thanks! :)