Page MenuHomePhabricator

PageForms token input autocomplete values cannot be unselected
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
https://sandbox.semantic-mediawiki.org/wiki/Sp%C3%A9cial:AjouterDonn%C3%A9es/Article/xxxxxx

Actual Results:
If you click in the field, a value gets suggested.
Clicking on the "x" seems to remove the value.
If you click outside of the field, e. g. to go to the next field, the value gets re-established in the field.

Expected Results:
Clicking on "x" should remove the value and the field should be left blank unless you click in the filed again.

Observedin PF versions 3.8, 3.9.3.
It does work as expected in PF 3.5.1
All are using MW 1.31.. The sandbox example uses PF 3.9.3 and MW 1.34

Event Timeline

Krabina created this task.Jun 8 2020, 2:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 8 2020, 2:25 PM
Krabina updated the task description. (Show Details)Jun 8 2020, 2:25 PM

This looks like it might be happening only because, for both "tokens" inputs in that form, there is only one pre-set value. Which would still be a bug, but a more minor one. Is that possible?

no, it also happens when more optiona are available. then the first one gets re-selected

Oh... okay - now I'm pretty sure it happens when there's "local" autocompletion, which happens when there are less than 100 possible values. Which is quite a bit worse than only happening when there's one value!

I figured this problem does also not exist in PF 3.6, so it must have started after that.

I believe this was fixed about a week ago, in the Page Forms code.

I can confirm that this is working in the current version.

Yaron_Koren closed this task as Resolved.Sep 18 2020, 1:19 PM
Yaron_Koren claimed this task.