Page MenuHomePhabricator

Use SpecialInvestigate::getTabParam when building a URL
Closed, ResolvedPublic

Description

URLs to particular tabs on Special:Investigate can be built using getTabParam and getTabName, since the URL param and tab name are the same (discussed in T253823#6204129).

However, it's more correct to use getTabParam. This also makes it easier to decouple the URL param and tab name in the future, if necessary.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 8 2020, 10:23 PM

Change 603642 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/CheckUser@master] SpecialInvestigate: Use getTabParam to build URLs

https://gerrit.wikimedia.org/r/603642

Change 602745 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/CheckUser@master] SpecialInvestigate: Use getTabParam to build URLs

https://gerrit.wikimedia.org/r/602745

Change 603642 abandoned by Tchanders:
SpecialInvestigate: Use getTabParam to build URLs

Reason:
Duplicate of Ic17dce362b899bfeb10988e5486cca2ef3d4ac54

https://gerrit.wikimedia.org/r/603642

Change 602745 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] SpecialInvestigate: Use getTabParam to build URLs

https://gerrit.wikimedia.org/r/602745

Niharika closed this task as Resolved.Jul 31 2020, 9:44 PM