Page MenuHomePhabricator

[Regression] Preview not visible in source mode
Closed, ResolvedPublic

Description

The preview in the Reply tool's source mode is not visible.

Behavior

  1. Visit: https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Cats
  2. Click any "Reply" link
  3. Switch to the tool's source mode if you are not already in it
  4. Start typing a comment (it doesn't matter what it includes)

Expected

  1. ✅ Notice a preview of the comment you are drafting appears below the text input

Actual

  1. ❗️Notice a preview of the comment you are drafting DOES NOT appears below the text input [i]

i. Preview not appearing

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2020, 12:22 AM
DLynch added a subscriber: DLynch.Jun 11 2020, 5:09 PM

I think the API response changed?

We do:

widget.$preview.html( response ? response.parse.text : '' );

...but the response content is such that response.parse.text['*'] would be needed.

@Esanders suggests that this might be an issue with 0cfc84aa29177025f34998d412e02692f47d5d67 not actually working.

Change 604804 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Follow-up Icb14766: Fix formatversion:2 param

https://gerrit.wikimedia.org/r/604804

Esanders raised the priority of this task from High to Unbreak Now!.Jun 11 2020, 5:28 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 11 2020, 5:28 PM

Change 604804 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Follow-up Icb14766: Fix formatversion:2 param

https://gerrit.wikimedia.org/r/604804

We should backport this.

Turns out the original bug (https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/DiscussionTools/+/602183/) was merged just after the cut, so no backport necessary.

ppelberg edited projects, added Skipped QA; removed Editing QA.
ppelberg closed this task as Resolved.Jun 15 2020, 9:34 PM
ppelberg claimed this task.

The source mode's preview is available on https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Cats: