Page MenuHomePhabricator

Secondary 'http' issue in Jade PromoteDialog
Closed, ResolvedPublic

Description

The promote label feature seems to have been affected by re-enabling the LinkSummary hooks
( secondary issue )

From @kevinbazira:

How to reproduce the secondary issue:

  • Create an edit on a page, go to the Jade page of this new edit and add the first proposal as an anonymous user.
  • The preferred label for the first proposal will be shown in the jade_diff_label table.
  • Then create a second proposal as a logged in user, and try to promote the second label. You will get a server error: 'http'

Event Timeline

ACraze created this task.Jun 11 2020, 12:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2020, 12:41 AM
ACraze claimed this task.Jun 11 2020, 12:42 AM
ACraze added a project: Jade.

Change 604816 had a related patch set uploaded (by Accraze; owner: Accraze):
[mediawiki/extensions/Jade@master] Reindex EntitySummarizer preferred list

https://gerrit.wikimedia.org/r/604816

@kevinbazira it looks like the EntitySummarizer was not reindexing the array being created during the LinkSummary hook, so there was a weird 'offset not found' error.

Change 604816 merged by jenkins-bot:
[mediawiki/extensions/Jade@master] Reindex EntitySummarizer preferred list

https://gerrit.wikimedia.org/r/604816

@ACraze, I have been able to promote a second label without the error and the jade_diff_label db table got updated successfully. Thank you for fixing this bug. I have +2'd.

Halfak closed this task as Resolved.Jun 22 2020, 4:35 PM