Page MenuHomePhabricator

Document Node not accessible by keyboard
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  • Launch a wiki page.
  • Navigate till "Edit " and hit enter
  • Navigate till "Insert" and navigate till "More" dropdown, hit enter.
  • Navigate till "Gallery" control, hit enter then navigate till "Option " and hit enter.

Actual Results:

  • Observe that "Gallery caption" editor not accessible through keyboard

Expected Results:

  • All element should be accessible by keyboard

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 12 2020, 9:09 PM

Just adding a tabindex fixes the problem – however, then you can't tab out of the caption editor, because we use the Tab for list item indentation (T172694). But this particular editor doesn't allow list items or indenting them, so maybe we can disable that.

@matmarex Disable the "no tab out" on this editor would be my vote in this case. since having and item not accessible by keyboard is not desired.

Change 605632 had a related patch set uploaded (by Bkudiess-msft; owner: Bkudiess-msft):
[VisualEditor/VisualEditor@master] Adds tabindex to document node

https://gerrit.wikimedia.org/r/c/VisualEditor/VisualEditor/ /605632

Change 605632 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Adds tabindex to document node

https://gerrit.wikimedia.org/r/605632

I don't think this is very functional without T172694, but sure, let's do it. It shouldn't hurt.

Change 612424 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (0cab1cfbb)

https://gerrit.wikimedia.org/r/612424

Change 612424 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (0cab1cfbb)

https://gerrit.wikimedia.org/r/612424

JTannerWMF closed this task as Resolved.Jul 22 2020, 5:26 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 22 2020, 5:26 PM

You can now tab into the "Gallery caption" field – you can't tab out of it though. That's covered by T172694: User can't tab out VisualEditor surfaces, e.g. comment input widgets, media dialog.