Page MenuHomePhabricator

Watchlist star gone on Vector
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Actual Results:

  • Next to Read, View source and View history there’s a tab called Watch.

Expected Results:

  • The last tab shows a star icon.

Further Details:

  • This affects only group0 wikis, not group1 or group2, so it arrived with wmf37 (T254174). Not sure if it’s a train blocker.
  • Both legacy and new Vector are affected.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 16 2020, 3:31 PM
Krinkle triaged this task as Unbreak Now! priority.Jun 16 2020, 4:04 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 16 2020, 4:04 PM

Probably caused by the Desktop Improvements work?

Possibly caused by ca71f762faadaa91be27d8c4c45babc111e59f49, but that landed in wmf.34, so it seems unlikely.

Change 605966 had a related patch set uploaded (by Aron Manning; owner: Aron Manning):
[mediawiki/skins/Vector@master] Restore Watchlist star

https://gerrit.wikimedia.org/r/605966

Demian added a subscriber: Demian.Jun 16 2020, 5:03 PM

Caused by .vector-tabs selector in patch 604858 instead of .vector-menu-tabs (code)

Change 605970 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/Vector@master] Revert "Replace deprecated classes with modern ones"

https://gerrit.wikimedia.org/r/605970

Change 605970 abandoned by Jdlrobson:
Revert "Replace deprecated classes with modern ones"

Reason:
Doesn't revert cleanly.

https://gerrit.wikimedia.org/r/605970

Change 605975 had a related patch set uploaded (by Jdlrobson; owner: Aron Manning):
[mediawiki/skins/Vector@wmf/1.35.0-wmf.37] Restore Watchlist star

https://gerrit.wikimedia.org/r/605975

Change 605966 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Restore Watchlist star

https://gerrit.wikimedia.org/r/605966

Mentioned in SAL (#wikimedia-operations) [2020-06-16T19:01:02Z] <brennen> holding 1.35.0-wmf.27 deploy to group1 for a few minutes while merging & testing fix for T255574

Mentioned in SAL (#wikimedia-operations) [2020-06-16T19:03:27Z] <brennen> CORRECTION: holding _1.35.0-wmf.37_ deploy to group1 for a few minutes while merging & testing fix for T255574

Change 605975 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.35.0-wmf.37] Restore Watchlist star

https://gerrit.wikimedia.org/r/605975

brennen closed this task as Resolved.Jun 16 2020, 7:51 PM

Tested and deployed.

Demian claimed this task.Jun 25 2020, 5:42 AM
Demian added a subscriber: Edtadros.