Page MenuHomePhabricator

Site: eqiad/codfw 2 VM request for releases
Closed, ResolvedPublic

Description

Labs Project Tested: n/a
Site/Location:EQIAD|CODFW
Number of systems: 2 (1 each)
Service: releases
Networking Requirements: internal
Processor Requirements: 2
Memory: 4GB
Disks: 128GB
Other Requirements: like releases1001/2001

Event Timeline

Dzahn created this task.Tue, Jun 16, 5:24 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Jun 16, 5:24 PM

Change 605996 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] DHCP: add releases1002/releases2002

https://gerrit.wikimedia.org/r/605996

Change 605996 merged by Dzahn:
[operations/puppet@production] DHCP: add releases1002/releases2002

https://gerrit.wikimedia.org/r/605996

Change 606006 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] site: add releases1002/releases2002 with insetup role

https://gerrit.wikimedia.org/r/606006

Mentioned in SAL (#wikimedia-operations) [2020-06-16T20:29:39Z] <mutante> signing puppet cert requests for releases1002 and releases2002 - T255590

Change 606006 merged by Dzahn:
[operations/puppet@production] site: add releases1002/releases2002 with insetup role

https://gerrit.wikimedia.org/r/606006

Dzahn closed this task as Resolved.Tue, Jun 16, 8:31 PM
Dzahn claimed this task.

cookbooks.sre.hosts.decommission executed by dzahn@cumin1001 for hosts: releases1002.eqiad.wmnet

  • releases1002.eqiad.wmnet (PASS)
    • Downtimed host on Icinga
    • Found Ganeti VM
    • VM shutdown
    • Started forced sync of VMs in Ganeti cluster ganeti01.svc.eqiad.wmnet to Netbox
    • Removed from DebMonitor
    • Removed from Puppet master and PuppetDB
    • VM removed

Mentioned in SAL (#wikimedia-operations) [2020-06-23T15:12:55Z] <mutante> removing ganeti VM releases1002 in eqiad row_A - will recreate in another row to re-balance (T255590)

Change 607305 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] move releases1002 from row A to row to rebalance VMs

https://gerrit.wikimedia.org/r/607305

Change 607305 merged by Dzahn:
[operations/dns@master] move releases1002 from row A to row to rebalance VMs

https://gerrit.wikimedia.org/r/607305

Change 607362 had a related patch set uploaded (by Wolfgang Kandek; owner: Wolfgang Kandek):
[operations/puppet@production] install_server: update MAC address for releases1002

https://gerrit.wikimedia.org/r/607362

Change 607363 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] DHCP: update MAC address for releases1002

https://gerrit.wikimedia.org/r/607363

Change 607363 abandoned by Dzahn:
DHCP: update MAC address for releases1002

Reason:
duplicate of https://gerrit.wikimedia.org/r/c/operations/puppet/ /607362 created for demo purposes

https://gerrit.wikimedia.org/r/607363

Change 607362 merged by Wolfgang Kandek:
[operations/puppet@production] install_server: update MAC address for releases1002

https://gerrit.wikimedia.org/r/607362

Mentioned in SAL (#wikimedia-operations) [2020-06-23T23:16:47Z] <wkandek> releases1002 is back after being moved to row D (T255590)