Page MenuHomePhabricator

Add linebreak (again) to Monolingual text
Closed, ResolvedPublicBUG REPORT

Description

Please see structured data of this file. Long monolingual text runs out of the box.

I am pretty sure that this is a regression. If not feel free to correct me.

Event Timeline

Raymond created this task.Jun 18 2020, 6:09 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptJun 18 2020, 6:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ramsey-WMF changed the subtype of this task from "Task" to "Bug Report".
Ramsey-WMF added a subscriber: Ramsey-WMF.

seems like a regression.

Change 606648 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Don't allow long content (e.g. strings, monolingual text) to increase width

https://gerrit.wikimedia.org/r/606648

I think I introduced this regression while improving support for IE11 (https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseMediaInfo/+/604298)
I've submitted a new patch to fix this.

Change 606648 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Don't allow long content (e.g. strings, monolingual text) to increase width

https://gerrit.wikimedia.org/r/606648

CBogen added a subscriber: CBogen.EditedJun 23 2020, 5:50 PM

@matthiasmullie is this ready for QA? If so, can you move it to the QA column and tag Elena and let her know? Thanks!

This should hit production later today, but can already be tested on betacommons now.

Etonkovidova closed this task as Resolved.Jun 26 2020, 12:13 AM

Checked in betalabs - the text seems to be properly wrapped:

desktopmobile

Note: adding ellipsis to long text might be a good option.

The file reported in the task description looks as the following (wmf.38):