Page MenuHomePhabricator

Newcomer tasks: Post-edit dialog suggested edit card is missing the wikidata description
Closed, InvalidPublic

Description

Actual desktop
Expected desktop
Actual mobile
Expected mobile

The wikidata description from the design is not shown in the card.

It should appear with 4px space after the article title and overflow into an ellipsis after 1 line
(the article title should be able to overflow to 2 lines max.)

Event Timeline

RHo created this task.Jun 18 2020, 7:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2020, 7:57 PM
Tgr closed this task as Invalid.Jun 25 2020, 5:26 PM
Tgr added a subscriber: Tgr.

Articles on our test sites are not linked to Wikidata. Sorry, I should have mentioned on the post-edit task that this part is hard to test. You could set something up manually (there's test.wikidata.org for testwiki and wikidata.beta.wmflabs.org for the beta sites) but the easier approach is to test the post-edit dialog in production without actually making an edit, by clicking through a suggested edit card and then typing this in the browser console:

mw.config.get( 'ge-suggestededit-session' ).postEditDialogNeedsToBeShown = true;
mw.config.get( 'ge-suggestededit-session' ).maybeShowPostEditDialog();

@Tgr -- I just went and made a suggested edit in my personal account on Czech Wikipedia, and I noticed that the dialog did not have a Wikidata description. Is that because the topic is not in Wikidata?

Tgr added a comment.Jun 26 2020, 12:40 AM

Probably (not linked to a WD item or the item does not have a description in Czech - I'd expect the former to be rare, the latter to be not so rare). Or maybe there's a non-deterministic bug. I can see the Wikidata description some of the time on cswiki, at least.

Marshall asked me to test this out, and I did a test edit from SE, and I see this:

According to the task's description, I believe that's expected.

I've checked the case Marshall has, and the cause seems to be missing Wikidata description - that's actually quite common :-).

I assume we can keep this closed?

Great, thank you!