Page MenuHomePhabricator

Call to private Comment::__construct() from context 'CommentsPage'
Closed, ResolvedPublicBUG REPORT

Description

2020-06-21 12:17:40 mw5 shiropediawiki: [257ddcbd6f56612ec9a0ca1c] /w/index.php?title=%E5%9F%8E%E3%83%9A%E3%83%87%E3%82%A3%E3%82%A2:%E6%97%A5%E5%B8%B8%E4%BC%9A%E8%A9%B1&action=edit   Error from line 245 of /srv/mediawiki/w/extensions/Comments/includes/CommentsPage.php: Call to private Comment::__construct() from context 'CommentsPage'
#0 /srv/mediawiki/w/extensions/Comments/includes/CommentsPage.php(480): CommentsPage->getComments()
#1 /srv/mediawiki/w/extensions/Comments/includes/parser/DisplayComments.php(83): CommentsPage->display()
#2 /srv/mediawiki/w/includes/parser/Parser.php(4293): DisplayComments::getParserHandler(NULL, array, Parser, PPFrame_Hash)
#3 /srv/mediawiki/w/includes/parser/PPFrame_Hash.php(328): Parser->extensionSubstitution(array, PPFrame_Hash)
#4 /srv/mediawiki/w/includes/parser/Parser.php(3330): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#5 /srv/mediawiki/w/includes/parser/Parser.php(1489): Parser->replaceVariables(string)
#6 /srv/mediawiki/w/includes/parser/Parser.php(593): Parser->internalParse(string)
#7 /srv/mediawiki/w/includes/content/WikitextContent.php(368): Parser->parse(string, Title, ParserOptions, boolean, boolean, NULL)
#8 /srv/mediawiki/w/includes/content/AbstractContent.php(555): WikitextContent->fillParserOutput(Title, NULL, ParserOptions, boolean, ParserOutput)
#9 /srv/mediawiki/w/includes/EditPage.php(4120): AbstractContent->getParserOutput(Title, NULL, ParserOptions)
#10 /srv/mediawiki/w/includes/EditPage.php(4025): EditPage->doPreviewParse(WikitextContent)
#11 /srv/mediawiki/w/includes/EditPage.php(2811): EditPage->getPreviewText()
#12 /srv/mediawiki/w/includes/EditPage.php(703): EditPage->showEditForm()
#13 /srv/mediawiki/w/includes/actions/EditAction.php(55): EditPage->edit()
#14 /srv/mediawiki/w/includes/MediaWiki.php(511): EditAction->show()
#15 /srv/mediawiki/w/includes/MediaWiki.php(302): MediaWiki->performAction(Article, Title)
#16 /srv/mediawiki/w/includes/MediaWiki.php(900): MediaWiki->performRequest()
#17 /srv/mediawiki/w/includes/MediaWiki.php(527): MediaWiki->main()
#18 /srv/mediawiki/w/index.php(44): MediaWiki->run()
#19 {main}

Event Timeline

Paladox created this task.Jun 21 2020, 2:54 PM
Restricted Application added a project: Social-Tools. · View Herald TranscriptJun 21 2020, 2:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
ashley closed this task as Resolved.Jun 24 2020, 5:43 AM
ashley assigned this task to Paladox.

As we discussed on IRC, this was apparently caused by an incompatibility between Comments and MediaWiki-extensions-CommentStreams, for the constructor method for Comments' Comment class was, is, has always been and remains public. Your CommentStreams patch hopefully addressed this incompatibility in an adequate manner.