Page MenuHomePhabricator

ERROR: Unable to retrieve pages on Special:MultiPageEdit
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

go to Special:MultiPageEdit and click a template

Actual Results:
no table appears only the message "ERROR: Unable to retrieve pages"

Expected Results:
Editable table of articles that use the template

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2020, 10:04 AM

What version of Page Forms and MediaWiki are you running? And do you see any JavaScript errors in the console?

MW 1.34.1
Page Forms 4.9.3 (3e10c0a) may 21 2020 à 17:54

error in console :

Failed to load resource: the server responded with a status of 403 ()

Response of api query :

Invalid file extension found in the path info or query string.

which is triggered in the file MediaWikiFolder/includes/WebRequest.php

Theoretically this bug won't appears with MW 1.35+ because there is no more Internet Explorer 6 compatibility 😃

Oh... does this only happen with IE?

No I get it on Chrome Version 83.0.4103.116 (Build officiel) (64 bits)

The related error

Invalid file extension found in the path info or query string

occurs because of page name ends with

.ca

It's a pure MediaWiki incorrect behaviour which is fix in 1.35 (but not in 1.34 or less)

Is this issue resolved now? Or is there something more that can be done in Page Forms?

I will try again in MW 1.35 when stable version will be released to check if it's fix.

I will try again in MW 1.35 when stable version will be released to check if it's fix.

@Nicolas_NALLET: 1.35 has been released; does this still happen? (If I understand you correctly; if not please clarify which version of what.)

Good news ! I cannot see this error anymore with MW 1.35 and Page Forms 4.9.5 (70295d4)

Yaron_Koren closed this task as Resolved.Mon, Nov 9, 8:19 PM