Page MenuHomePhabricator

Empty space in Ask your mentor dialogue
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Go to the homepage (sr.wiki)
  2. Click "Ask your mentor a question"

Actual result:
You can see that there is a lot of empty space at the bottom of the box. The problem occurs on all projects that use GrowthExperiments.

Expected result:
There shouldn't be that much empty space. :)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2020, 2:17 PM

@Acamicamacaraca: Assuming this task is about the GrowthExperiments-Homepage, hence adding that project tag so other people who don't know or don't care about team tags can also find this task when searching via projects.

@Acamicamacaraca: Assuming this task is about the GrowthExperiments-Homepage, hence adding that project tag so other people who don't know or don't care about team tags can also find this task when searching via projects.

Yes. Thank you!

Thanks @Acamicamacaraca - I moved the task to the current sprint team workboard.

MMiller_WMF moved this task from Inbox to Upcoming Work on the Growth-Team board.Jun 26 2020, 2:42 AM

You're welcome :). It is in everyone's interest to solve these small problems.

Tgr added subscribers: RHo, Tgr.Aug 17 2020, 1:21 PM

I thought this was intentional (it's from applying the same size constraints we used for the help panel, since the two are sort of the same internally). @RHo am I misremembering?

RHo added a comment.Aug 17 2020, 2:40 PM

I thought this was intentional (it's from applying the same size constraints we used for the help panel, since the two are sort of the same internally). @RHo am I misremembering?

Hi @Tgr - unfortunately I can't confirm as I was on leave during the design and implementation of the mentor dialog. However, given that this scneraio shows the question inside a centered dialog instead of the help panel which has a specific pinned position and size, I agree with this task to change it standard OOUI dialog window-frame dependent applied height and width:
Example expected dimensions in 1024px wide window:

MMiller_WMF assigned this task to Tgr.Aug 17 2020, 5:18 PM

@Tgr is going to work on this one.

Change 620772 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Remove large space in homepage mentor dialog and increase question box

https://gerrit.wikimedia.org/r/620772

Changed to standard OOUI dialog size. This still includes some empty space, but much less:


We could make it fully dynamic, but I figured UI consistency with other dialogs is preferable.

Change 620772 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Remove large space in homepage mentor dialog and increase question box

https://gerrit.wikimedia.org/r/620772

Looks good, with same comment as T256908 around allowing vertically resizing of the textarea only as a very minor improvement.

MMiller_WMF closed this task as Resolved.Sep 2 2020, 12:01 AM

Thank you!