Page MenuHomePhabricator

Enabled dark mode no works on changing browser
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

  • Log in on gerrit-test.wikimedia.org
  • Go in settings
  • Make Dark theme (alpha) enabled

Actual Results:
When enabled, Gerrit will reload and show UI in dark theme. But, change browser and log in your account.

When you log in your account using another browser, you won't have dark theme and you will have to enable it again.

This can be reproduced and in incognito mode of browser.

Expected Results:
If user save some setting on own account, it should be saved always.

Event Timeline

Kizule created this task.Jun 22 2020, 11:25 PM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptJun 22 2020, 11:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Kizule updated the task description. (Show Details)Jun 22 2020, 11:27 PM

The theme uses your local storage, so if your using private mode, then you will have issues.

The theme uses your local storage, so if your using private mode, then you will have issues.

But... Why I have to enable theme in settings over and over on changing browser or using incognito mode?

Well because changing themes uses the local browser storage. So it won't transfer based on account.

Kizule closed this task as Invalid.Jun 22 2020, 11:38 PM

Umm, okay. I understand..

Dzahn added a subscriber: Dzahn.EditedJun 22 2020, 11:39 PM

I am not too surprised by this behaviour. If the user settings are stored locally, as paladox points out, then how would they get from one browser to another. One browser wouldn't be able to write to storage of another, hopefully.

This comment was removed by Kizule.