Page MenuHomePhabricator

Certain links being rejected by caching if opened in Internet Explorer with a HTTP 400 error
Closed, InvalidPublic

Description

I was just told by a fellow cswiki user that V1 links at https://cs.wikipedia.org/w/index.php?title=Wikipedista:David_V./P%C3%ADskovi%C5%A1t%C4%9B/1&oldid=18758517 cannot be opened in Internet Explorer. If one attempts to do so, an internal error appears.

Varnish XID 455128687

User agent: Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko

Event Timeline

Urbanecm created this task.Jun 24 2020, 6:58 PM
Restricted Application added a project: SRE. · View Herald TranscriptJun 24 2020, 6:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm updated the task description. (Show Details)Jun 24 2020, 7:00 PM

@Urbanecm: What is the exact HTTP error type? Asking as that screenshot does not include any error message (probably not to expose the IP).

At least on the "Varnish Webrequest 50X" dashboard I cannot find any results for uri_host:"cs.wikipedia.org" AND referer:"Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko" but I'm probably looking in the wrong place...

@Aklapper: Here you are, this is the complete message.

Request from (REDACTED) via cp3062 frontend, Varnish XID 675554498
Upstream caches: cp3062 int
Error: 400, Bad Request at Wed, 01 Jul 2020 06:55:25 GMT
Aklapper renamed this task from Certain links being rejected by caching if opened in Internet Explorer to Certain links being rejected by caching if opened in Internet Explorer with a HTTP 400 error.Jul 1 2020, 8:41 AM
ema triaged this task as Medium priority.Jul 2 2020, 9:22 AM
ema added a subscriber: ema.Jul 2 2020, 9:26 AM

Interesting, I'd be inclined to think that the issue here cannot be simply the user agent or we would know. :-)

  • Is the problem reproducible reliably?
  • Does it happen from different networks?
  • Is there possibly some sort of "smart" box in between the user and our servers? Web firewalls, or what not.
ema moved this task from Triage to Caching on the Traffic board.Jul 2 2020, 9:26 AM
BBlack moved this task from Caching to Bug Reports on the Traffic board.Sep 29 2020, 9:44 PM
ema closed this task as Invalid.Nov 26 2020, 3:05 PM

Timing out given that 5 months have passed since this issue was reported and to the best of my knowledge it was an isolated case. Feel free to reopen if it happens again obviously.