Page MenuHomePhabricator

Empty "In other languages" section appeared in the sidebar on Timeless
Closed, ResolvedPublic

Description

This section was not there before latest update (4-6 weeks of code) of translatewiki.net.

Event Timeline

I suspect it is caused by rSTIMb46734465699: Timeless: support SidebarBeforeOutput hook. It looks like that an extension on translatewiki.net defines afterPortlet content for the languages section, but there are no languages to render, and Timeless doesn't actually show the afterPortlet content, resulting in an empty portlet. CC'ing @Ammarpad as author.

Only such extensions we have would be ULS or Translate, to my knowledge.

Ammarpad claimed this task.EditedJun 25 2020, 1:10 PM

I can see that here https://translatewiki.net/wiki/FAQ?useskin=timeless.

It does not happen with other skins so I believe the problems lies with Timeless handling of the portlet header (not content). Because if it were content, I'd expect monobook https://translatewiki.net/wiki/FAQ?useskin=monobook (or vector) to show the content, but they don't, as there's none.

Change 607820 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/skins/Timeless@master] Fix lang portlet header display.

https://gerrit.wikimedia.org/r/607820

Change 607820 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Fix lang portlet header display.

https://gerrit.wikimedia.org/r/607820

Jdlrobson closed this task as Resolved.Jul 7 2020, 3:54 PM