Page MenuHomePhabricator

Opening Echo flyout undefines $.widget.extend (jQuery UI) if there are past notifications
Closed, ResolvedPublicBUG REPORT

Description

To replicate, go to any page in your browser console:

If jQuery UI is loaded:

  • typeof $.widget -> function
  • typeof $.widget.extend -> function

If it isn't:

  • typeof $.widget -> undefined
  • typeof $.widget.extend -> TypeError

Then click to open your Echo notifications. On wikis where I've never received notifications, nothing changes. On wikis where I have any number of notifications, past or present, I'll now see:

  • typeof $.widget -> object
  • typeof $.widget.extend -> undefined

This can break things that rely on jQuery UI if they're used after someone checks their notifications.

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptJun 26 2020, 10:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Amorymeltzer changed the subtype of this task from "Task" to "Bug Report".Jun 26 2020, 10:24 AM
Amorymeltzer updated the task description. (Show Details)Jun 26 2020, 2:05 PM

I can confirm this problem on using Echo. But sometimes $.widget.extend is undefined on my watchlist after same time although I didn't used Echo.

@Fomafix Can you still see this? I'm no longer able to replicate it, so I'm hoping this got fixed somewhere.

I also can't reproduce the problem anymore.

Jdlrobson closed this task as Resolved.Wed, Oct 28, 5:59 PM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

I'm not seeing any more instances of the error in the production log in the last 7 days, so I think this is indeed resolved per https://phabricator.wikimedia.org/T256466#6576181