Page MenuHomePhabricator

Regression: Redlinks not styled as such on mobile web
Closed, ResolvedPublic

Description

All red-links appear as blue to me on the mobile version of the English-language Wikipedia, also I get signed out randomly from Wikimedia websites, perhaps these things are unrelated but they happened at the same time. All red-links appear blue, I will add screenshots below.

QA Results - Beta

ACStatusDetails
1T256503#6268404

QA Results -Prod

ACStatusDetails
1T256503#6275262

Event Timeline

DonTrung created this task.Fri, Jun 26, 7:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Jun 26, 7:11 PM

Blue link in the "Mobile" mode.

Red link in the "Desktop view" mode.

For context, I have this issue on Microsoft Windows 10 Mobile (Microsoft Edge - Microsoft Lumia 950 XL) and Google's Android OS (Ecosia browser - Elephone P8 Mini), so this is not limited to either one device, one operating system, or one browser. Let's see if anyone else can reproduce this on their devices.

Notice the link "Presentation coin" (a special type of coin in Chinese culture countries akin to a European commemorative medal), which is a red-link in desktop, but a blue-link in desktop mode.

Update, this also applies to Wikimedia Commons.

Note that these deleted files appear "not-so-deleted" on Mobile, this can potentially cause problems if one thinks that a file can still be used on another Wikimedia website. Also, still seems to apply to multiple devices, browsers, and operating systems.

Pcoombe renamed this task from I can't see any redlinks in the English Wikipedia to Redlinks not styled as such on mobile web.Fri, Jun 26, 10:18 PM
Pcoombe added a subscriber: Pcoombe.

Redlinks correctly have class="new", but the CSS doesn't appear to actually style this red.

Ammarpad triaged this task as High priority.EditedSat, Jun 27, 7:20 AM
Ammarpad added a subscriber: Ammarpad.
In T256524, @JohanahoJ wrote:

In Minerva on Wikipedia, redlinks are blue when the user is logged in, but they are red again when logged out.

Actually for me, it is the same in both cases. Logged in or out. Caused by r605001

Ammarpad claimed this task.Sat, Jun 27, 7:21 AM
In T256524, @JohanahoJ wrote:

In Minerva on Wikipedia, redlinks are blue when the user is logged in, but they are red again when logged out.

Actually for me, it is the same in both cases. Logged in or out. Caused by r605001

On Safari+iPadOS redlinks are red when I am logged out, but there was a misunderstanding in a report I got on Chrome+Android, where they apparently are blue in both cases. Sorry about that!

patilise added a subscriber: patilise.

Change 608117 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/skins/MinervaNeue@master] Restore redlink color property.

https://gerrit.wikimedia.org/r/608117

Change 608117 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Restore redlink color to .new link elements

https://gerrit.wikimedia.org/r/608117

He7d3r added a subscriber: He7d3r.Sun, Jun 28, 11:16 AM
Jdlrobson renamed this task from Redlinks not styled as such on mobile web to Regression: Redlinks not styled as such on mobile web.Mon, Jun 29, 4:44 PM
Jdlrobson reassigned this task from Ammarpad to Edtadros.
nray moved this task from Needs triage to MinervaNeue on the Mobile board.Mon, Jun 29, 11:20 PM

Test Result - Beta

Status: ✅ PASS
Environment: beta
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhone 11 Pro Max

Test Artifact(s):

QA steps

✅ AC1: Verify red links that appear on Desktop also appear red on Mobile.
I was able to confirm that the links in production that are shown in the bug do appear red on desktop but blue on mobile. In beta the behavior is working as expected.

DesktopMobile
Edtadros updated the task description. (Show Details)Tue, Jun 30, 4:48 PM

It's fixed. Thank you all for your amazing work. 😊

Test Result - Prod

Status: ✅ PASS
Environment: enwiki
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhone 11 Pro Max

Test Artifact(s):

QA steps

✅ AC1: Verify red links that appear on Desktop also appear red on Mobile.
I was able to confirm that the links in production that are shown in the bug do appear red on desktop but blue on mobile. In beta the behavior is working as expected.

DesktopMobile
Edtadros reassigned this task from Edtadros to ovasileva.Thu, Jul 2, 4:42 PM
Edtadros updated the task description. (Show Details)
Edtadros added a subscriber: Edtadros.
ovasileva closed this task as Resolved.Mon, Jul 6, 12:09 PM

Red links back to normal.