Page MenuHomePhabricator

Clicking on a project name in the "Repo" column, only open patches are shown for that repo, not any patches as in 2.15
Closed, DeclinedPublic

Description

Steps to reproduce

  1. Click on project name (i.e. next to the patch name on home page)
  2. Note the difference between Gerrit 2.15 and 3.2

Expected behavior
I would expect to see both open and merged patches sections as it was in Gerrit 2.15.

Current behavior
I get only open patches, I have to navigate to project settings to visit project dashboard in Gerrit 3.2

Configuration
Firefox 77

Event Timeline

Dvorapa created this task.Jun 28 2020, 9:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2020, 9:22 AM
Aklapper renamed this task from If I click on a project name, I get open patches, not project dashboard as in 2.15 to Clicking on a project name in the "Repo" column, only open patches are shown for that repo, not any patches as in 2.15.Jun 28 2020, 9:32 AM

I assume this is about the "Repo" table column on https://gerrit.wikimedia.org/r/dashboard/self which links to https://gerrit.wikimedia.org/r/q/project:FOOBAR+status:open ?

I hope this task will be declined as I don't see why the old behavior was better than the new behavior. If you think it was then please provide a use case. :)

I know I might be weird, but I can not see any easy option to find merged patches to a project, which is a good way (for example) to look for regressions, comment merged patchsets (as a good way to communicate about regressions), revert merged patches, etc. The new behavior makes the work with Gerrit quite disturbing and it seems as a bug as some other Gerrit instances I used last time does support project dashboards.

In old gerrit the links are going to the project dashboard. The dashboards are exists and "Recent Changes Recent open and merged changes." is the default, but when it is not linked, than there is not helpful to have them.

Just using links from the documentation brings you there:
https://gerrit.wikimedia.org/r/p/mediawiki/core/+/dashboard/default:recent

Aklapper closed this task as Declined.Jul 2 2020, 9:22 AM

I'm boldly declining this because developers are usually more interested what's there to do (same for Phabricator boards: by default they only show open tasks).
You can edit the search query in the search field in the top bar and remove the status:open if wanted.

But that would just show all things (even abandoned) and not in distinct categories, which is usually quite cluttered. To me this is a huge regression, that perhaps bothers just me (as I was using the dashboard all the time), but as it does not bother anyone else, noone want to make effort to fix this.

I mean this is a fair point to me. Project Dashboards are much more novice-friendly than just list of open changes and a search field, for sure.