Page MenuHomePhabricator

Make Gerrit test instance at https://gerrit.git.wmflabs.org work again or update docs (replaced by https://gerrit.devtools.wmflabs.org/)
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Open https://wikitech.wikimedia.org/wiki/Gerrit_test_instance
  2. Be happy about the information written there and click the link with excitement

Expected behavior
Gerrit test instance like beta wikis should open

Current behavior
HTTP 404

Configuration
Firefox 77

Event Timeline

Dvorapa created this task.Jun 28 2020, 9:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2020, 9:24 AM
Aklapper renamed this task from Make Gerrit test instance work again or update docs to Make Gerrit test instance at https://gerrit.git.wmflabs.org work again or update docs.Jun 28 2020, 9:37 AM
Dvorapa updated the task description. (Show Details)Jun 28 2020, 9:41 AM
Kizule added a subscriber: Kizule.Jun 28 2020, 9:44 AM

As we have gerrit-test.wikimedia.org, I think that we should redirect gerrit.git.wmflabs.org to gerrit-test.wikimedia.org, or update docs really.

Nice, this is what I looked for last 12 months at least :D

Ok.. On wikitechwiki we have only one page (per search results), on mediawikiwiki nothing.

Someone, or I, can update page from description of this task.

Note though that gerrit-test.wikimedia.org will go away at some point (probably soon), as it lived in the production environment (T254644).

But IIRC @Paladox said to set up a Gerrit instance in labs again.

@Paladox: Is there a linkable ticket for that?

QChris closed this task as Resolved.Jul 3 2020, 2:19 PM
QChris claimed this task.
QChris added a subscriber: Dzahn.

There is a new working Gerrit in labs https://gerrit.devtools.wmflabs.org/
That got set up by @Dzahn and @Paladox

I've updated links on https://wikitech.wikimedia.org/wiki/Gerrit_test_instance accordingly. (But that page is scarce nonetheless)

Kizule added a comment.EditedJul 3 2020, 3:38 PM

There is a new working Gerrit in labs https://gerrit.devtools.wmflabs.org/
That got set up by @Dzahn and @Paladox

I've updated links on https://wikitech.wikimedia.org/wiki/Gerrit_test_instance accordingly. (But that page is scarce nonetheless)

Thanks! Can you document somewhere how to do make own instance of Gerrit, because I'm trying to make it, but no works (I can't get it loaded).

Dzahn reopened this task as Open.Jul 3 2020, 4:34 PM
Dzahn claimed this task.
Dzahn added a comment.Jul 7 2020, 2:14 AM

@Zoranzoki21 I would really recommend requesting access to the existing devtools project if you want to test something. It is MUCH easier than repeating all the steps that were needed to make the puppet role work in a cloud project.

And that can still mean different things. It can mean to use an existing instance (ideally not the one with "prod" in the name) or to create a new one.

If you really wanted to set one up in a different project for some reason then it's possible but not trivial and needs some resources, both from you and from wmcs.

Nevertheless i have written https://wikitech.wikimedia.org/wiki/Gerrit_test_instance#Create_your_own_Gerrit_test_instance which gives a rough overview what it means.

Dzahn closed this task as Resolved.Jul 7 2020, 8:42 PM

https://gerrit-test.wikimedia.org has been removed today. It was always meant to be a temp setup for this specific major upgrade.

A new test instance also with 3.2 exists in cloud as described above.

@Zoranzoki21 I hope that resolves it. If you would like to chat about the specific problem you had feel free to ping me on IRC. Or open here and let me know if this answers it.

Dzahn renamed this task from Make Gerrit test instance at https://gerrit.git.wmflabs.org work again or update docs to Make Gerrit test instance at https://gerrit.git.wmflabs.org work again or update docs (replaced by https://gerrit.devtools.wmflabs.org/).Jul 7 2020, 9:45 PM