Page MenuHomePhabricator

Unbreak gerrit-replica web UI on gerrit2001
Closed, DeclinedPublic

Description

https://gerrit-replica.wikimedia.org/r/ reports Not Found

It was said thaht the web UI is currently not used, hence we do not need to work on it.

But it turns out people (try to) use it.

[10:09:25] <legoktm>	 very few people will ever see it, but https://gerrit-replica.wikimedia.org/r/login is missing the image and probably all static resources
[10:10:11] <legoktm>	 (I only ever log in to -replica to be able to see the monitoring graphs)

(from https://wm-bot.wmflabs.org/logs/%23wikimedia-operations/20200628.txt )

So we should fix it.

Event Timeline

QChris created this task.Jun 28 2020, 12:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2020, 12:57 PM

Change 608214 had a related patch set uploaded (by QChris; owner: Christian Aistleitner):
[operations/puppet@production] gerrit: Use gerrit-replica.wikimedia.org as canonical host for gerrit2001

https://gerrit.wikimedia.org/r/c/operations/puppet/ /608214

Peachey88 updated the task description. (Show Details)Jun 28 2020, 12:59 PM
QChris closed this task as Declined.Jul 22 2020, 8:32 PM

Making the web UI work, would need more than just a few adaptions. Hence, declining.

If we want to make it work at some point, it might be easier to run with the replica gerrit as normal master but with the readonly plugin installed.

Change 608214 abandoned by QChris:
[operations/puppet@production] gerrit: Use gerrit-replica.wikimedia.org as canonical host for gerrit2001

Reason:
While this change would make the proxy work, to make the Gerrit replica work behind the proxy would need further changes, which would be more work than we're willing to take on for the moment.

https://gerrit.wikimedia.org/r/608214

hashar added a subscriber: hashar.Jul 29 2020, 8:53 AM

In another task I looked at having some bots to use gerrit query on the replica instead of on the master and asked upstream about it. The issue is that there is no secondary index on the replica hence query is explicitly disabled. I guess the same goes for the web UI. I can't imagine Gerrit web ui working properly without a secondary index.

If one attempts to login via https://gerrit-replica.wikimedia.org/r/login , it get redirects to the master instance, though I am apparently logged in just fine since I can then access the monitoring page at https://gerrit-replica.wikimedia.org/r/monitoring . So it is a bit awkward, but at least admins have access to that monitoring page ;)