Page MenuHomePhabricator

Unable to automerge exported i18n patched
Closed, ResolvedPublic

Description

Since today I am getting an error when running the export script for MediaWiki.

The first commit for core ( https://gerrit.wikimedia.org/r/c/mediawiki/core/+/608286 ) is committed but merge fails:

/home/betawiki/config/bin/merge-wmgerrit-patches 'mediawiki/core'

In Process.php line 235:

 The command "/home/betawiki/config/bin/merge-wmgerrit-patches 'mediawiki/core'" failed.

 Exit Code: 123(Unknown error)

 Working directory: /scratch/raymond

 Output:
 ================


 Error Output:
 ================
 fatal: "c,1" is not a valid patch set

Probably because Gerrit was updated last weekend.

QA plan

Affected projects: translatewiki.net
Tested in production.

Outcome

Fixed an issue, caused by Gerrit upgrade, that broke regular software translation updates from translatewiki.net.

Event Timeline

Raymond created this task.Jun 29 2020, 10:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2020, 10:56 AM
Raymond updated the task description. (Show Details)Jun 29 2020, 10:57 AM
ssh "${GERRIT[@]}" gerrit query --format=TEXT "owner:$U" "project:$1" status:open |
(grep '  url:' || true) | # Handle pipefail from grep
cut -d/ -f5 |
sort |
xargs -I ____ ssh "${GERRIT[@]}" gerrit review ____,1 --code-review 2

I guess the gerrit output has changed

Raymond updated the task description. (Show Details)Jun 29 2020, 11:09 AM

Change 608292 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[translatewiki@master] Fix merge-wmgerrit-patches after gerrit upgrade

https://gerrit.wikimedia.org/r/c/translatewiki/ /608292

Change 608292 merged by jenkins-bot:
[translatewiki@master] Fix merge-wmgerrit-patches after gerrit upgrade

https://gerrit.wikimedia.org/r/c/translatewiki/ /608292

Raymond closed this task as Resolved.Jun 29 2020, 3:00 PM

Thank you for the fast fix

Nikerabbit updated the task description. (Show Details)Jun 29 2020, 3:05 PM