Page MenuHomePhabricator

{{SUBPAGENAME}} no longer returning the title for pages without subpages
Closed, ResolvedPublic

Description

As a consequence of https://gerrit.wikimedia.org/r/c/mediawiki/core/+/605185, which was for T229443, the {{SUBPAGENAME}} variable stopped returning the page title if the current page is not a subpage (this was also reported by @Soda at T229443#6272892). Quick comparison table for the value of {{SUBPAGENAME}}:

titlepreviouscurrent
Foo/Bar'Bar''Bar'
Foo'Foo'''

Judging from the task, this was not intentional, and it can (and does) break stuff on wiki (I've witnessed a report of a broken template), so the previous behaviour should be restored.

Event Timeline

Daimona created this task.Jul 1 2020, 9:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2020, 9:56 PM
Daimona claimed this task.Jul 1 2020, 9:59 PM
Krinkle triaged this task as High priority.Jul 1 2020, 10:02 PM
Krinkle added a project: Platform Engineering.
Krinkle added a project: MW-1.35-release.

Change 608843 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@master] Revert "Title: fix subpage split for degenerate cases"

https://gerrit.wikimedia.org/r/c/mediawiki/core/ /608843

Change 608964 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/core@master] title: Make getSubpageText() return the title text if there's no subpage

https://gerrit.wikimedia.org/r/c/mediawiki/core/ /608964

Change 608971 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[operations/mediawiki-config@master] Use RejectParserCacheValue to reject parser output from 19:10–22:40 UTC

https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/ /608971

Change 608971 merged by jenkins-bot:
[operations/mediawiki-config@master] Use RejectParserCacheValue to reject parser output from 19:10–22:40 UTC

https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/ /608971

Krinkle reassigned this task from Daimona to daniel.Jul 1 2020, 11:21 PM
Krinkle added a subscriber: Krinkle.

I've reverted the patch in-branch and configured MW to lazily invalidate the 3 hours of bad parser cache entries.

@daniel There's a patch by @Daimona for master that seems to fix this. I'll let you review and beta-verify that. I didn't go with it right away because I wanted to give you some time to look at this from other angles and maybe check if there are other cases we have missed, so that we can land it relaxedly in master ahead of the next branch.

Unblocking this train, speculatively blocking the next.

(The dark areas of my brain reminded me of T208181: {{FULLPAGENAME}} no longer works for the Special namespace but had to realize that's a different one.)

Could this also have triggered T256878: Items in bread-crumb trail not shown any longer as GeoCrumbs calls getSubpageText() for the $linkText?

Daimona added subscribers: RolandUnger, Andyrom75.

Could this also have triggered T256878: Items in bread-crumb trail not shown any longer as GeoCrumbs calls getSubpageText() for the $linkText?

I'd say yes. In fact, the breadcrumbs are now working as expected (fix was backported yesterday night).

daniel added a comment.Jul 2 2020, 8:35 PM

I got the expected behavior wrong for getSubpageText() when writing the fix for getBaseText(). Sorry about that.

Change 608964 merged by jenkins-bot:
[mediawiki/core@master] title: Make getSubpageText() return the title text if there's no subpage

https://gerrit.wikimedia.org/r/608964

Change 608843 abandoned by Daniel Kinzler:
[mediawiki/core@master] Revert "Title: fix subpage split for degenerate cases"

Reason:
Better fix is merged I0928f85c862d3b2baf49317

https://gerrit.wikimedia.org/r/608843

This is now Resolved, right?

Krinkle closed this task as Resolved.Jul 6 2020, 7:23 PM