Page MenuHomePhabricator

Minimized help panel displayed when a page loads
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. From Homepage SE go to any SE article.
  2. While SE article loads, the minimized Help panel (the Help button) would be briefly displayed:

The animated gif below shows it in action:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2020, 10:17 PM
MMiller_WMF added a subscriber: RHo.

@RHo -- is this desired? Or a bug?

RHo added a comment.Jul 2 2020, 10:31 AM

@RHo -- is this desired? Or a bug?

This is definitely a bug. Not sure if this is related to the work occurring on T255255: Newcomer tasks: Enable easier toggling to open and close Desktop help panel?

Tgr added a comment.Jul 5 2020, 7:58 PM

This is definitely a bug. Not sure if this is related to the work occurring on T255255: Newcomer tasks: Enable easier toggling to open and close Desktop help panel?

I don't think it's related, but won't it be obsoleted by that change? If the button is always visible, there is no harm in it being displayed a split second before the panel animates up - it might even be a good thing.

RHo added a comment.Jul 6 2020, 5:51 AM

This is definitely a bug. Not sure if this is related to the work occurring on T255255: Newcomer tasks: Enable easier toggling to open and close Desktop help panel?

I don't think it's related, but won't it be obsoleted by that change? If the button is always visible, there is no harm in it being displayed a split second before the panel animates up - it might even be a good thing.

Yes, by "related" I meant it more as a question as to whether it was being inadvertently caused by work in progress on the in that task. Once the new animation (on loading SE tasks on desktop, the panel opens from the button) is completed, presumably this should no longer occur.
However, it's worth noting that for cases where the panel doesn't open on default (such as when it's a plain help panel when a user opens a non-newcomer task), we would still want the call to action button to animate onto the screen.

We currently believe that when T255255: Newcomer tasks: Enable easier toggling to open and close Desktop help panel is merged, we will no longer have this issue. Moving to the QA column so that @Etonkovidova can check it.

Etonkovidova closed this task as Resolved.Sat, Jul 25, 12:12 AM
Etonkovidova claimed this task.

Re-checked - the changes in UI- T255255- resolved the issue. With introduced oo-ui-icon-help oo-ui-image-invert icon, visually it looks logical (the button is part of the guidance panel, so to say) to have the icon appears first and then loading the guidance panel.
This issue was about appearing unrelated minimized Help button, so since it's not an issue now - marking the bug report as Resolved due to related fixes/re-desgn work.

the animated gif shows the current behavior: