Page MenuHomePhabricator

VisualEditor manual references box clicking doesn’t work with the new iPadOS 13.4 mouse cursor
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  • get an iPad with iPadOS 13.4 and a connected mouse/trackpad (on Safari)
  • open a Wiki page with VisualEditor
  • click “cite” and open the references box
  • click on Manual
  • Try to select anything in the manual section with the cursor

Actual Results:

it doesn’t work and the selection doesn’t work

it works only touching, not using the cursor

Expected Results:

the desired selection works

Video link

Event Timeline

Ferdi2005 created this task.Jul 3 2020, 2:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 3 2020, 2:28 PM

Change 609451 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/Citoid@master] Fix keyboard accessibility of the manual citation options

https://gerrit.wikimedia.org/r/609451

I am not sure how this patch will work on the iPad, but I assume its funky cursor relies on the usual keyboard/screenreader accessibility features, so it should help.

matmarex claimed this task.Jul 3 2020, 4:11 PM
matmarex added a project: Accessibility.

Change 609451 merged by jenkins-bot:
[mediawiki/extensions/Citoid@master] Fix keyboard accessibility of the manual citation options

https://gerrit.wikimedia.org/r/609451

matmarex added a project: Skipped QA.

@Ferdi2005 The fix is available on Beta now (e.g. https://en.wikipedia.beta.wmflabs.org/wiki/Dido_Sotiriou), I'd appreciate if you could test it out and check if it works well for you on the iPad.

@matmarex, it doesn’t work :( Now the Manual section buttons light up but if I click them I get the same behaviour as always: the cite box closes itself and nothing happens.
This is anyway an enhancement, so nice work!

Video link

@Esanders will test this on his ipad when it arrives

@Esanders will need to get a trackpad/mouse too!

I verified this fix on the live site with iOS 14 beta. @Ferdi2005 does this work for you now in iOS13.4?

ppelberg added a subscriber: ppelberg.

I verified this fix on the live site with iOS 14 beta. @Ferdi2005 does this work for you now in iOS13.4?

Moving this to "Blocked" pending confirmation from Ferdi2005 on the above.

@Esanders @ppelberg I can confirm that when I open the manual section of the references box and click with the cursor of the trackpad on one of the buttons of that box, the references box disappears and I can’t add any manual reference. This doesn’t happen when I tap with the finger or the cursor itself, this happens only when I click, as seen in the video before.

JTannerWMF added a subscriber: iamjessklein.

@iamjessklein will test this on her ipad by connecting a bluetooth mouse

Unfortunately, I can't test this as I don't have working bluetooth mouse right now. This task needs to be reassigned.

cc @JTannerWMF @ppelberg

JTannerWMF reassigned this task from Esanders to DLynch.Aug 19 2020, 5:17 PM

David will test it

Tested it just now, albeit on iPadOS 14. The bug still occurs exactly as described -- using the mouse to select one of the items in the manual-cite dialog just closes the dialog while removing the selection from the document entirely.

DLynch removed DLynch as the assignee of this task.Aug 25 2020, 5:38 PM
DLynch added a subscriber: DLynch.

Tested it just now, albeit on iPadOS 14. The bug still occurs exactly as described -- using the mouse to select one of the items in the manual-cite dialog just closes the dialog while removing the selection from the document entirely.

I am using 14beta5 and can't get it to fail at all.

Hmm... @Esanders, I'm using a bluetooth trackpad, are you using a trackpad or mouse? (I have no idea whether this would make a difference, but...)

DLynch renamed this task from VisualEditor manual references box clicking doesn’t work with the new iPadOS 13.4 cursor to VisualEditor manual references box clicking doesn’t work with the new iPadOS 13.4 mouse cursor.Aug 25 2020, 9:19 PM
DLynch updated the task description. (Show Details)

(Out of curiosity I tried this on my iPhone running iOS 13.6.1 with a USB mouse and the issue did not occur.)

@matmarex in desktop mode?

I tested desktop and mobile sites, using a BT mouse.

DLynch assigned this task to matmarex.Aug 26 2020, 2:39 PM

I just tested it again, and now it works for me. So, best guess would be some random beta hiccup on Monday? (There is sometimes a delay while the specialized template dialog opens, so maybe a spectacularly well timed network / caching issue bit me?)

@matmarex in desktop mode?

Yes

ppelberg closed this task as Resolved.Aug 29 2020, 1:15 AM

T257046#6412797, T257046#6410126 and T257046#6410835 lead me to think this issue is fixed.

@Ferdi2005, if you experience otherwise, please let us know.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 29 2020, 1:15 AM