Page MenuHomePhabricator

Horizontal misalignment of open sidebar on Wikipedias on widescreen
Closed, ResolvedPublic3 Estimated Story Points

Description

This might be an unresolvable issue, nonetheless should be captured:
The open sidebar links are misaligned horizontally on canvas size above 1700px:

Event Timeline

Volker_E created this task.Jul 8 2020, 1:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 8 2020, 1:43 AM

@Volker_E nice catch. I think ultimately this will be dependent upon the width of the icon within the logo area. I believe we could increase the width of the workspace container slightly such that at least for all Wikipedia sites it lines up nicely.

ovasileva triaged this task as High priority.Jul 10 2020, 11:51 AM

The issue is the margin-left on .skin-vector-max-width .mw-workspace-container. This is however only needed when the sidebar is collapsed. We may want to consider dropping the margin-left here and shifting the margin-left to #left-navigation instead.

@Volker_E we might want to consider limiting the scope of this task to "when the layout is at max-width". At anything less than max-width the position of the sidebar is dynamic (until it locks to the side of the screen), so getting it to line up with something in the header might not make sense.

ovasileva lowered the priority of this task from High to Medium.Sep 9 2020, 4:33 PM
ovasileva set the point value for this task to 3.Sep 9 2020, 4:39 PM

Change 627508 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/Vector@master] Adjust the left-alignment of the sidebar

https://gerrit.wikimedia.org/r/627508

Jdrewniak removed Jdrewniak as the assignee of this task.Sep 17 2020, 5:07 PM
Jdrewniak assigned this task to Volker_E.
Jdrewniak added a subscriber: Jdrewniak.

Change 627508 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Adjust the left-alignment of the sidebar

https://gerrit.wikimedia.org/r/627508

ovasileva claimed this task.Wed, Oct 7, 5:13 PM
ovasileva closed this task as Resolved.Tue, Oct 13, 11:10 AM