Page MenuHomePhabricator

Interface issues: replace absolute links with interwiki prefixes; use “as” instead of “at”?, use variables for NowCommons template name and Import File button
Closed, ResolvedPublic2 Estimated Story Points

Description

Several suggestion for interface messages in FileImporter:

  1. Is it possible to use interwiki prefixes instead of absolute URLs in the following messages?
    1. MediaWiki:Fileimporter-help-banner-text ([[c:, [[mw:, [[w:en:)
    2. MediaWiki:Fileimporter-input-page-info-text ([[m:)
  2. In both following messages, $1 variable is supposed to be an URL according to qqq doc. So shouldn’t the word “as” replaced with “at”?
    1. MediaWiki:Fileimporter-cleanup-summary
    2. MediaWiki:Fileimporter-delete-summary
  3. Since Meta is a namespace on Metawiki, you may probably want to use m: interwiki prefix instead of meta: in following message to make it work well on metawiki:
    1. MediaWiki:Fileimporter-commonshelper-missing-config
  4. The NowCommons template name should probably be localized, as in MediaWiki:Fileimporter-cleanup-text:
    1. MediaWiki:Fileimporter-help-banner-text
  5. In MediaWiki:Fileimporter-help-banner-text, Import File button label is literally quoted, that should be replaced with {{int:Fileimporter-specialpage}}.

(I have opened only one task because one message contains several issues, and one issue concerns several message, so I didn’t know how to split them.)

Event Timeline

Pols12 created this task.Jul 8 2020, 6:14 PM
Lena_WMDE set the point value for this task to 2.Jul 21 2020, 12:20 PM
Lena_WMDE moved this task from Backlog to Default version backlog on the Move-Files-To-Commons board.

Change 615211 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/FileImporter@master] [WIP] Relative wiki links instead of weblinks in messages

https://gerrit.wikimedia.org/r/615211

JJMC89 added a subscriber: JJMC89.Jul 21 2020, 3:34 PM

Interwikilinks should not be used in the interface messages since they may not be configured or not have the same target on non-WMF wikis.

Interwikilinks should not be used in the interface messages since they may not be configured or not have the same target on non-WMF wikis.

Non-WMF wikis should not link to Commons, Meta-Wiki or a Wikipedia template at all, in my humble opinion.

Non-WMF wikis should not link to Commons, Meta-Wiki or a Wikipedia template at all, in my humble opinion.

I can tell you from experice that some do regularly, especially to the English Wikipedia. InstantCommons even facilitates any wiki using media from Commons.

Ideally all of the linked pages should be on MediaWiki wiki or when that is not possible the message customized for WMF ising WikimediaMessages or on wiki.

Change 615211 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Use {{SITENAME}} and absolute weblinks in all messages

https://gerrit.wikimedia.org/r/615211

For item #2, the problem is actually in the qqq doc: it says $1 is an URL whereas it is a linked filename according to T227358. So as is probably more appropriate, but the doc should be updated to say $1 is a file name (not a URL).

What's described in T227358 was not fully possible. We had to use URLs instead.

We discussed this a bit in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/FileImporter/+/615211/ (see the comments over there), and decided to change it to "at", as originally suggested.

thiemowmde closed this task as Resolved.Aug 11 2020, 10:08 AM
thiemowmde claimed this task.