Page MenuHomePhabricator

upgrade git-review to >= 1.27 on all stretch hosts across the board
Closed, ResolvedPublic

Description

Since Gerrit has been upgraded to version 3.2 (T254158) it requires
a git-review version of at least 1.27 or git-review will stop working.

The current version in stretch was just 1.25.

This first became an issue on Toolforge bastions as reported in T257496.

From there we noticed it is also installed on some stat* hosts that are still on stretch.

https://debmonitor.wikimedia.org/packages/git-review

The package needs to be upgraded and reinstalled on these hosts or users won't be able to use git-review / gerrit.

Event Timeline

Dzahn created this task.Jul 9 2020, 6:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2020, 6:40 PM
Dzahn added a comment.Jul 9 2020, 6:42 PM

per T257496#6294709

I imported the buster 1.27 package to stretch (first tested on mwdebug1001, then imported on apt.wikimedia.org with includedeb).

Removed the manually installed package again and then confirmed i could install it with apt-get.

The toolforge part will be covered in its existing task.

The remaining hosts affected are:

stat1004.eqiad.wmnet (host)
stat1006.eqiad.wmnet (host)
stat1007.eqiad.wmnet (host)

Mentioned in SAL (#wikimedia-operations) [2020-07-09T18:44:37Z] <mutante> stat1004, stat1006, stat1007 - upgrading git-review package from 1.25 to 1.27 so that it keeps working with new Gerrit 3.2 (T257609)

Dzahn added a subscriber: Bstorm.Jul 9 2020, 6:45 PM
Dzahn renamed this task from update git-review to >= 1.27 on all stretch hosts across the board to upgrade git-review to >= 1.27 on all stretch hosts across the board.Jul 9 2020, 6:47 PM
Dzahn closed this task as Resolved.
Dzahn claimed this task.
Dzahn updated the task description. (Show Details)

Upgraded the package on stat1004, stat1006 and stat1007 (apt-get update, apt-get install git-review).

https://debmonitor.wikimedia.org/packages/git-review now shows it is gone.