Page MenuHomePhabricator

Introduce new Repo entityterms API and remove hack from Client pageterms API
Closed, ResolvedPublic

Description

The WikibaseClient action=query&prop=pageterms API currently has special behavior on Repo wikis, where it returns the terms of the entity page instead of the terms of the entity linked to that page. We will introduce a new WikibaseRepo API module for this purpose, action=query&prop=entityterms, and then (after following the notification policy of the stable interface policy) remove that special behavior from the pageterms API.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 10 2020, 9:46 AM

Change 611282 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] Add entityterms Repo API

https://gerrit.wikimedia.org/r/611282

Change 611282 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Add entityterms Repo API

https://gerrit.wikimedia.org/r/611282

Change 612549 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] Remove repo hack from pageterms API

https://gerrit.wikimedia.org/r/612549

Lucas_Werkmeister_WMDE changed the task status from Open to Stalled.Jul 15 2020, 4:24 PM

Stalled until wmf.2 has been branched (since we effectively announced the pageterms change would be deployed with wmf.3).

Change 612549 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Remove repo hack from pageterms API

https://gerrit.wikimedia.org/r/612549

Lucas_Werkmeister_WMDE closed this task as Resolved.Aug 7 2020, 1:54 PM
Lucas_Werkmeister_WMDE claimed this task.

Working as intended on Wikidata – pageterms of Wikidata:Project chat now returns “Project:Village pump”, entityterms of Q42 returns “Douglas Adams”.