Page MenuHomePhabricator

Create Wikipedia Kotava
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikipedia Kotava.

  • Local file uploads: disabled

Thank you.


Pre-install automatic checklist:

The Wiki is ready to be created.


Post install automatic checklist:


Step by step commands:
On deploy1001:
cd /srv/mediawiki-staging/
git fetch
git log -p HEAD..@{u}
git rebase
On mwmaint1002:
scap pull
mwscript extensions/WikimediaMaintenance/addWiki.php --wiki=aawiki avk wikipedia avkwiki avk.wikipedia.org
On deploy1001:
scap sync-file dblists "Creating avkwiki (T257943)"
scap sync-wikiversions "Creating avkwiki (T257943)"
scap sync-file wmf-config/InitialiseSettings.php "Creating avkwiki (T257943)"
scap sync-file static/images/project-logos/ "Creating avkwiki (T257943)"
scap sync-file langlist "Creating avkwiki (T257943)"
scap update-interwiki-cache

End of automatic output

Event Timeline

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptTue, Jul 14, 4:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 612888 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/dns@master] Add avk to the langlist helper

https://gerrit.wikimedia.org/r/612888

Change 612894 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMessages@master] Add avkwiki messages

https://gerrit.wikimedia.org/r/612894

@MF-Warburg Could you please clarify "Etc/GMT"? I'm not sure what that means.

Change 612897 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Initial configuration for avkwiki

https://gerrit.wikimedia.org/r/612897

Urbanecm triaged this task as Low priority.Wed, Jul 15, 4:42 PM

Change 612894 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add avkwiki messages

https://gerrit.wikimedia.org/r/612894

Change 612888 merged by Dzahn:
[operations/dns@master] Add avk to the langlist helper

https://gerrit.wikimedia.org/r/612888

Dzahn added a subscriber: Dzahn.Wed, Jul 15, 6:03 PM

18:00 < mutante> !log DNS - new language 'avk' has been added - This language is called Kotava and is "a proposed international auxiliary language (IAL) that focuses especially on the principle of cultural neutrality". Learn more at https://en.wikipedia.org/wiki/Kotava

avk.wikipedia.org is an alias for dyna.wikimedia.org.
Dzahn updated the task description. (Show Details)Wed, Jul 15, 6:09 PM
Dzahn moved this task from Backlog to Working on on the User-Urbanecm board.

I'm test-administrator of this project in the Incubator. If some precisions are needed, I can give them, I think. Cheers.

@Urbanecm
Hi!
Etc/GMT is the code for Greenwich international hour.
Since Kotava is an international auxiliary language, we think this default affectation is logical.

The code is from [[wikipedia:List_of_tz_database_time_zones]] (middle of the list), as:
Status : Canonical
UTC offset ±hh:mm : +00:00
UTC DST offset ±hh:mm : +00:00

Meno25 added a subscriber: Meno25.Sat, Jul 18, 3:44 PM
jhsoby updated the task description. (Show Details)Mon, Jul 20, 10:15 PM

Hi!
A precision that can be useful. In Kotava, the standard for most punctuation marks, as ( ) ~ ; « » ! ? – —, they must be separated from the text, by unbreakable spaces. For this reason, it has become customary to insert them in articles in the form of (&nbsp; &nbsp;) ~&nbsp; &nbsp;; «&nbsp; &nbsp;» &nbsp;! &nbsp;? etc. Unless a better solution* could be found, they should be kept by not converting to simple spaces.

  • I would gladly suggest the possibility of having new, simple "magic symbols" for writing articles in the future.

For example, by __ or ::

  • (__ | __ ) : (::Europa::) = (&nbsp;Europa&nbsp;)
  • «:: | ::» : «::Europa::» = «&nbsp;Europa&nbsp;»
  • ::? : Tokdume__? = Tokdume&nbsp;?
  • ~__ : ~__gindik kaliyir. = ~&nbsp;gindik kaliyir.

etc.

Ciao. Quando sarà disponibile il nuovo spazio avk.wikipedia.org? Grazie.

Ciao. Quando sarà disponibile il nuovo spazio avk.wikipedia.org? Grazie.

Quoting from Wiki-Setup (Create): "Creating new wikis is not a priority for Operations / Wikimedia-Site-requests, as it's a cumbersome process that involves many steps and many people. Therefore some time can elapse between the approval of the creation and the actual creation of the wiki. Please be patient. Thanks for your understanding."

Yes and also worth mentioning that some steps need time to take into affect otherwise the created wiki will be broken. Do you want to have a broken wiki that doesn't work?

@Urbanecm, @Ladsgroup, I'm not aware of the technical difficulty of these operations, so please forgive me. And this project is quite big since it already counts more than 10000 articles and every day 10 or 20 new ones are created. I'm in a hurry to stop having to put the wp/avk prefix everywhere. And a thousand thanks in advance to you for your work for the whole community. Mile grazie. :)

@ClaudiaVisentini Sure, I totally understand that eagerness :). I just wanted to point out that it's not like "pressing a button".

Dcljr added a subscriber: Dcljr.Sun, Jul 26, 1:32 AM

Hi!
A precision that can be useful. In Kotava, the standard for most punctuation marks, as ( ) ~ ; « » ! ? – —, they must be separated from the text, by unbreakable spaces.
[...]

This can/should be discussed elsewhere. I have offered my own suggestions at incubator:User talk:Nevatovol.

@Urbanecm should this new wiki be used to try and reproduce T235885: DannyS712 wasn't attached to SUL at banwiki? See T235885#5587060 for (theoretical) reproduction steps

Well, if you want, that is fine with me - if you need anything imported, ping me on IRC and I'll be happy to do that for you.

Let's create this wiki on s5.

Well, if you want, that is fine with me - if you need anything imported, ping me on IRC and I'll be happy to do that for you.

Sure. I've flagged this task so that I won't forget. Any idea when the wiki is scheduled to go live?

Urbanecm added a comment.EditedMon, Jul 27, 1:18 PM

At the earliest, when all wikis are at wmf.1. The plan is to do so sometime this week.

Change 612897 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for avkwiki

https://gerrit.wikimedia.org/r/612897

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:12:02Z] <urbanecm@deploy1001> Synchronized wmf-config/db-eqiad.php: Creating avkwiki (T257943) (duration: 01m 05s)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:14:27Z] <urbanecm@deploy1001> Synchronized wmf-config/db-codfw.php: Creating avkwiki (T257943) (duration: 01m 06s)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:15:41Z] <urbanecm@deploy1001> Synchronized dblists: Creating avkwiki (T257943) (duration: 01m 06s)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:24:19Z] <urbanecm@deploy1001> rebuilt and synchronized wikiversions files: Creating avkwiki (T257943)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:26:03Z] <urbanecm@deploy1001> Synchronized static/images/project-logos/: Creating avkwiki (T257943) (duration: 01m 06s)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:27:15Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Creating avkwiki (T257943) (duration: 01m 03s)

Mentioned in SAL (#wikimedia-operations) [2020-07-29T12:28:34Z] <urbanecm@deploy1001> Synchronized langlist: Creating avkwiki (T257943) (duration: 01m 05s)

Change 617111 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[analytics/refinery@master] Add avkwiki to analytics whitelist

https://gerrit.wikimedia.org/r/617111

Urbanecm closed this task as Resolved.Wed, Jul 29, 12:49 PM
Urbanecm claimed this task.

Wiki is live.

Change 617112 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/services/restbase/deploy@master] Add avkwiki to restbase

https://gerrit.wikimedia.org/r/617112

Change 617113 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/services/cxserver@master] Add avkwiki to cxserver

https://gerrit.wikimedia.org/r/617113

Change 617113 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Add avkwiki to cxserver

https://gerrit.wikimedia.org/r/617113

Xqt changed the status of subtask T259119: Add avkwiki to Pywikibot from Open to Stalled.Wed, Jul 29, 4:59 PM

A thousand thanks to you! (Kunon grewav !, in Kotava). The wiki is now alive. But I don't see any of the pages created...!? :(

Nintendofan885 added a comment.EditedThu, Jul 30, 10:28 AM

But I don't see any of the pages created...!? :(

Somebody will eventually import the pages from the Incubator project

jhsoby updated the task description. (Show Details)Fri, Jul 31, 8:13 PM
jhsoby added a subscriber: jhsoby.

Import from Incubator is done now.

Nintendofan885 changed the status of subtask T259119: Add avkwiki to Pywikibot from Stalled to Open.Sat, Aug 1, 9:50 AM
Meno25 removed a subscriber: Meno25.Mon, Aug 3, 4:16 PM

Change 618525 had a related patch set uploaded (by KartikMistry; owner: KartikMistry):
[operations/deployment-charts@master] Update cxserver to 2020-08-05-070016-production

https://gerrit.wikimedia.org/r/618525

Change 618525 merged by jenkins-bot:
[operations/deployment-charts@master] Update cxserver to 2020-08-05-070016-production

https://gerrit.wikimedia.org/r/618525