Page MenuHomePhabricator

1.36.0-wmf.8 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.36.0-wmf.8
Release Date
Mon, Sep 7, 12:00 AM
Backup Conductor
LarsWirzenius

2020 week 37 1.36-wmf.8 Changes wmf/1.36.0-wmf.8

This MediaWiki Train Deployment is scheduled for the week of Monday, September 7th:

Monday September 7thTuesday, September 8thWednesday, September 9thThursday, September 10thFriday
Backports only.Branch wmf.8 and deploy to Group 0 Wikis.Deploy wmf.8 to Group 1 Wikis.Deploy wmf.8 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.8 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.36.0-wmf.7
Next: 1.36.0-wmf.9

Event Timeline

mmodell created this task.Jul 14 2020, 8:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 14 2020, 8:19 PM
thcipriani assigned this task to jeena.Aug 11 2020, 10:11 PM
thcipriani triaged this task as Medium priority.
thcipriani updated Backup Conductor, added: LarsWirzenius.

Change 625745 had a related patch set uploaded (by DannyS712; owner: trainbranchbot):
[mediawiki/core@wmf/1.36.0-wmf.8] Branch commit for wmf/1.36.0-wmf.8

https://gerrit.wikimedia.org/r/625745

Change 625745 merged by jenkins-bot:
[mediawiki/core@wmf/1.36.0-wmf.8] Branch commit for wmf/1.36.0-wmf.8

https://gerrit.wikimedia.org/r/625745

hashar added a subscriber: hashar.Tue, Sep 8, 7:13 PM

T262507 is a fairly minor CSS issue that appears to be caused by the train.

T262507 is a fairly minor CSS issue that appears to be caused by the train.

I have made it a train blocker since that is a regression introduced that got introduced with this week deployment ( https://en.wikipedia.org/ is not affected and is running 1.36.0-wmf.6 at this time).

T262507 is a real blocker, some stylesheets are loaded out of order which leads to UI glitches. (<hr> disappearing, redlinks changing color and whatever else we haven't seen yet). There is a patch pending review that, once merged, will need to be cherry picked and deployed.

Mentioned in SAL (#wikimedia-operations) [2020-09-10T20:20:50Z] <longma> correction: T257976 - 1.36.0-wmf.8 to all wikis

jeena closed this task as Resolved.Fri, Sep 11, 7:29 PM